Mt300n - Cannot get second WiFi network to work

We are attempting to use two WiFi networks in order to create a mesh network.

Typically we have 1 wlan interface attached to a “wlan” WiFi SSID and 1 wireless “mesh” interface attached to a “mesh” Ad-Hoc SSID. This works perfectly on many routers we have used including the 6416 model from GL-inet.


However, when attempting to set this up with the mt300n, WiFi will ONLY work if we have 1 and only 1 SSID enabled in Network>Wireless. If we have 2 networks enabled, neither network works. Why is this happening and how do we resolve it so that we can use multiple networks on a single device?



You do not supply a lot of information on the devices or methodology, so it’s difficult to help, but this post suggests that there may be some hardware limitations. OpenWrt Forum Archive There are know issues in bridging with a single radio, which may not be directly relevant Client Mode Wireless [Old OpenWrt Wiki]

The 6416 is Atheros and the mt300N is Mediatek, so I would start looking into the protocols and their hardware limitations. I would also check to see what your other hardwares were that did play nice together.

I have attached a set of 3 screenshots to show you what I mean.

When I have one SSID, everything works fine. Whether it’s in Station/Master mode or in Ad-hoc, it works properly.

But if I have BOTH enabled, neither works. What SHOULD happen is I should see the network names of both the nearby ad-hoc connections and my phone’s mac address connected at the same time. But I don’t. Why? Are you suggesting that this chip is not capable of hosting 2 WiFi networks? That has been a solved problem for 15 years for consumer devices- I’d be really surprised if that was the case!

I have also tried to test dual SSID’s with the BOTH in Master/AP/Station mode. devices do not connect to either of the networks.

Occasionally, what I will see is my phone (MAC 5E:49) connect to BOTH SSIDs- which it should NOT be doing since one is AD-HOC and it doesn’t connect to Ad-hoc connections. It’s like the phone tries to connect to one but is forced to connect to both.


Here is the config in my mt300n in etc/config/wireless:


config wifi-device 'radio0'
option type 'mac80211' option path '10180000.wmac' option country 'CN' option txpower '20' option noscan '1' option channel '11' option hwmode '11g'


config wifi-iface
option device ‘radio0’
option ifname ‘wlan0’
option encryption ‘none’
option ssid ‘wlan’
option mode ‘ap’
option network ‘wlan’


config wifi-iface
option device ‘radio0’
option ifname ‘wlan0’
option encryption ‘none’
option ssid ‘PittMesh-Backhaul’
option mode ‘adhoc’

option network ‘mesh’

@Adam, MT300 is MTK chips, not Atheros. I wonder if the mesh driver can work with MTK chips. I didn’t try. But I can try after Easter holiday.

@Alfie Yes, after trying numerous things and reading some reports it appears that RangerZ is correct that AP + adhoc mode on MTK chips DOES NOT WORK. So these boards are NOT going to work for mesh networking.


Wait- what “mesh driver” are you talking about?



batman is said to be run only in Atheros chips

Have you tried 802.11s?

Atheros chips are the preferred chips for mesh networks around the world- especially the 9 series since 10 (802.11ac) does not support ad-hoc mode well apparently. We have 25ish nodes up and running (about 50 routers total) on a network that have OLSR and adhoc mode running now. I don’t know anyone who actually runs 802.11s. We SHOULD run BATMAN but we don’t. maybe we will one day.

anyway- mesh “driver”?

Driver: I mean BATMAN, it is a kernel module.