MT300N-V1 opkg update error

My original (factory) MT300n-v1 failed “opkg update”, so I upgraded FW the latest version 2.265, but “opkg update” still fails, with the same signature errors:

Downloading http://www.gl-inet.com/openwrt/ramips/2.263/packages/base/Packages.gz.
Downloading http://www.gl-inet.com/openwrt/ramips/2.263/packages/base/Packages.sig.
Signature check failed.
Remove wrong Signature file.
… … … …

For your information, my opkg.conf, after upgrade, is as follows:

dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay
option check_signature 1

And my distfeeds.conf is as follows:

src/gz chaos_calmer_base http://www.gl-inet.com/openwrt/ramips/2.263/packages/base
src/gz chaos_calmer_luci http://www.gl-inet.com/openwrt/ramips/2.263/packages/luci
src/gz chaos_calmer_management http://www.gl-inet.com/openwrt/ramips/2.263/packages/management
src/gz chaos_calmer_packages http://www.gl-inet.com/openwrt/ramips/2.263/packages/packages
src/gz chaos_calmer_routing http://www.gl-inet.com/openwrt/ramips/2.263/packages/routing
src/gz chaos_calmer_telephony http://www.gl-inet.com/openwrt/ramips/2.263/packages/telephony
src/gz chaos_calmer_oldpackages http://www.gl-inet.com/openwrt/ramips/2.263/packages/oldpackages
src/gz chaos_calmer_node http://www.gl-inet.com/openwrt/ramips/2.263/packages/node

The FW version 2.265 folder has a different distfeeds.conf:

src/gz glinet_core http://download.gl-inet.com/releases/kmod-3.0/ramips/mt7620
src/gz glinet_base http://download.gl-inet.com/releases/packages-3.x/ramips/base
src/gz glinet_gli_pub http://download.gl-inet.com/releases/packages-3.x/ramips/gli_pub
src/gz glinet_packages http://download.gl-inet.com/releases/packages-3.x/ramips/packages
src/gz glinet_luci http://download.gl-inet.com/releases/packages-3.x/ramips/luci
src/gz glinet_routing http://download.gl-inet.com/releases/packages-3.x/ramips/routing
src/gz glinet_telephony http://download.gl-inet.com/releases/packages-3.x/ramips/telephony
src/gz glinet_glinet http://download.gl-inet.com/releases/packages-3.x/ramips/glinet

But even when with this list I still get the same signature errors.

How can I get around this problem?

Latest testing firmware is 3.100

Finally got around to update to the test version 3.100-1217. Unfortunately it bricked my unit. Even factory reset cannot recover it.

I still have working units and am still looking for a solution to the signature failure, because I need to opkg install some modules. Any suggestions? Much obliged!

Did you update via gui?

If so perhaps try reloading via uboot?

Oh and latest firmware is now 3.102 or testing 3.104 :slight_smile:

Thanks for the quick response! I was able to unbrick my mt300n (v1) device using GUI, but only with FW image v2.265 from the mt300n/v1/ folder; the FW images from the mt300n-v2/v1/ folder did not work. The images in the latter folder are all labeled “v2” — are they supposed to work with v1 hardware?

The latest firmware for the old mt300n is here:

https://dl.gl-inet.com/firmware/mt300n/testing/

Oh poop. Sorry I didn’t pick up on the Version 1 the second post :confused:

My bad! :neutral_face: