MT300N-V2 Bricked

Hi,

I tried to update the firmware on my MT300N-V2 but for some reason it didn’t work and I have bricked the router.

I have followed the instructions here https://docs.gl-inet.com/en/2/troubleshooting/debrick/ but when I upload the firmware the screen says ‘Update in Progress’ and doesn’t change.

I left it for 20 mins and then I reverted the IP settings but the router still doesn’t work and I can’t access the router settings page.

Is there any other way of recovering the router?

1 Like

Uboot usually works without problem.

Can you pls check if you used the correct firmware http://download.gl-inet.com/firmware/mt300n-v2/v1/

Hi,

Thanks for responding, I’ve had another try at it and managed to get it working so it must have been something I wasn’t doing correctly.

Thanks

can you link the firmware you used? i already try a few and still the same problem, update never finish and the pc never gets and ip or the wifi

i changed the powercable and did the uboot upload again, and after 10min the page didn’t reload but the 2leds got fixed and the wifi got turned on