MT300N-V2 won't connect to phone

I have 2 gl-inet routers, a AR750N and a MT300N-V2. BOTH WORKED FINE.

A couple weeks ago the MT300N stopped connecting to the phone.

I’ve tried different power supplies, different cables, different phones. NOTHING connects. No power, no data.

Power supplies have ranged from 2.0 to 3.0A including 2.4A.
Cables have been at least a half dozen different USB3.1 or USB2 (with type-C adapter).
Phones have been ZTE Blade 7 and two different Mogo G7s.


At the same time these are all failing, the same power supplies, cables and phones ALL CONNECT SUCCESSFULLY to the AR750N.

I’ve rebooted numerous times. Reset it numerous times. I’ve hard-wired it to a laptop and gone into the settings. NOTHING has made any difference.

Is this thing dead? If NOT, how do I get it to connect to the cell phone?

If it is, I need to replace it… This is NOT a big-time special setup. It’s a charger with USB cable into the router, connected to a cell phone to get Verizon. Streaming and one laptop. Most of the time, one router is doing the streaming and the other is used by the laptop.

The three I found are
GL.iNet GL-AR300M16-Ext
GL.iNet GL300N-V2 – this is the one I currently have that’s dead…

These are ALL the same price within a dollar, but I’m not enough of an expert to know WHICH is the best choice for what I’m doing. AND, of course, time is limited as we’re leaving end-of-week for an extended trip and I need to get whichever of these is the best choice by then.

While seem it is died. Pls just talk to customer server to get exchange.

Unfortunately, when it died it was about 2 weeks past the 1 year… Bought on 7/24, received on 7/28, DIED on 8/15 or so…

I don’t figure customer service is going to do anything.

I’ll replace it with a router from a different company and hope their product has longer life.