Mudi GL-E750 doesn't work with Providers with IPv6

Hi,

I have got the mudi portable 4G LTE Router GL-E750.

I am very disappointed. I tried three different SIMs.

SIM from Deutsche Telekom: autosetup - did not work at all
SIM from Vodafone - only IPv4 did work (I expected dualstack)
SIM from Telefonica - IPv4 did work (Telefonica only provides CGN IPv4)
I expected a little bit more from a device with the only purpose of routing. A lot of cheaper smartphones provide problemfree hotspots under the same conditions - with IPv6, with dual stack with IPv6-only.

I tried also the latest prerelease /testing version. But it did not change. Where should I start to get it running?

Regards,
Thomas Schäfer

IPv6 is disable by default to prevent leak when using vpn.

To enable it, ssh to the router and do:

Modify this file and change all “1” to “0”
/etc/sysctl.d/99-disable-ipv6.conf

image

and execute

/etc/init.d/sysctl restart

It doesn’t help much.
The (Deutsche)Telekom-SIM still doesn’t work at all. The GUI says it is connected, but it doesn’t work.
With Vodafone (Germany) I still get only a IPv4-connection.
So I can’t reach my home computers.

Should I provide some log files? If yes, how should I do that?

Do you use teamviewer? We can do a remote assistant. So it will be easier than you provide log.

I installed teamviewer. I am ready now - for the next three hours. If this is bad for you, please make a proposal for a later date.
How I have to tell you the Teamviewer session ID?

Pls pm me. Can we connect your tomorrow morning? It will be my afternoon.

Tomorrow morning in CEST is Ok for me, but I haven’t found the PM-function in this forum. I see my inbox, but I don’t see a button “create message” or something similar.

Click on @alzhao name above his posts, and it’s the blue “Message” button for private message.

??

Oh interesting, you don’t have that button hmmm. Might be cos you are a new user?

@alzhao Can you start a PM to him?

Just did.
Just sent a message

I replied with the teamviewer ID/pw

It works now. Unfortunately I was on lunch. What should I do, if it happens again?
When is IPv6-access possible?

When changing from QMI to ttyUSB Internet works. I will check IPV6.

Which USB-port/device should be used?

ttyUSB3 is for data and ttyUSB2 is for command

2 Likes

Hello,

I do have exact the same issue here. Could you please provide solution in this thread?

Best regards,

Better describe more details. Thread is old. Firmware version also changed.

Despite the latest release 3.105 from 2020-12-07 15:29:22 the problem still persists.
Also with beta 3.201 no success.

Hi there,

in my case the following did help, but I’m noiw facing permanent reconnects (1 Minute-interval):

uci set glipv6.globals.enabled=1
uci commit glipv6.globals.enabled

uci set network.3g.ipv6=1 #enter correct interface-name instead of 3g
uci commit network.3g

edit file /etc/chatscripts/3g.chat:
OK ‘AT+CGDCONT=1,“IPV6”,"$USE_APN"’

Maybe these hints do help you out.

Best regards,

1 Like