Mudi (GL-E750) SMS Forwarding


Just tested the sms forwarding with multiple email account, but it looks like the Mudi only sends out a email, that it received the sms. The forwarded email doesn’t include the sms text. It looks like the functions not working correctly.

According to the FAQ it should send the text as well. Or did I set up something wrong?


It should send emails with the text. Which email did you use to sent from? gmail?

I tried gmail (both port 465 and 587 work) and my personal email-server. Both work and send out the confirmation email and the forwarded emails, but the sms text is missing in all of them.

Hi David,

Could you give me some samples of the missing SMS text? This might caused by text form.


Here is one send through my gmail account. Included the original full email data. Just removed some part of the phone number.
And a second example send through my personal email server.

1.) Example

> Bcc:
> Return-Path: <>
> Received: from ([])
>         by with ESMTPSA id lf4sm3462949pjb.0.2021.
>         for <>
>         (version=TLS1_3 cipher=TLS_CHACHA20_POLY1305_SHA256 bits=256/256);
>         Wed, 03 Feb 2021 18:29:32 -0800 (PST)
> Message-ID: <>
> Received: by (sSMTP sendmail emulation); Thu, 04 Feb 2021 03:29:28 +0100
> Date: Thu, 04 Feb 2021 03:29:28 +0100
> From:
> Subject: Gl-iNet Mudi SMS-Forward received a message from 1315818xxxx
> Content-Type: text/html;charset=UTF-8

Can’t send the second example, because I get an error message, that I can’t send two links as a new user.

Could you also provide the content of SMS text? Some kinds of content may fail when converting encoding format. Also, which firmware version are you using?

I am using firmware V3.105 - Dec 8, 2020.

Here is the SMS text “This is a test sms message”. Nothing special as a text.

I have included the email code that I received as a picture. It is a work around, because I get the error message, when I try to include it as a text.

I just check what text the web interface of my GL-E750 shows. And it looks like it is receiving the text plus some extra data.

I have included a picture of the web interface and the message.

Not sure were the extra text comes from.

Thanks for your information. I will have a test and locate the problem.

My apology for the late response, I have tested with E750 and received the forward email successfully.

From your screenshot, something was wrong when receiving the SMS, could you login to the router via SSH and show me the full SMS content? It should be in /etc/spool/sms/storage/.

If possible we can do a remote support via teamviewer.


I tried sending a sms from a different number to see, if that works. Still the same problem.

Here is the original email, SMS and the full SMS content (it was under /etc/spool/sms/incoming/)

Apparently, the transcoding process is ok, and the extra data shouldn’t be the cause.
May I have a remote check? You can add my skype if possible :

The problem was fixed by a test firmware. Thank to Riho-shuu!