Need to press abort/connect daily to get back internet.

This is an issue I’ve had since I bought it years ago, just got worse hence the thread.
Router: GL-MV1000 Brume.
Used as a simple wireguard client (mullvad) everything else “stock”
Issue: as title, loosing connection and have to login to router WEB UI and reboot or abort/connect
under VPN/WireGuard Client. This sometimes doesn’t happen for days, other times multiple times daily.
But today and yesterday it didn’t work no matter how many times I tried to reboot or reconnect/change server.
Unplugged it completely for 2hours watched a movie plugged it in. It worked, today changing servers multiple times and it worked.
Turning off vpn/kill switch gives me internet back.
I’ve tried purging all profiles, adding it again. That didn’t work since it happened again after that.

Another issue. The router web interface is snappy, I can press on anything in the UI Internet/Clients/Upgrade etc
But the second i press on VPN/WireGuard Client the web interface lags for a solid 5-10s is that normal?
It takes such a long times I’ve been just rebooting instead.
Not sure what to do next, I bought the router for easy wireguard client setup. Which it absolutely was.
But the issues has gone from an mild annoyance to not having internet for hours.

Please try 4.x firmware without keep setting