Network issue concerning GL-MT300N-V2


#1

Hi all,

GL-MT300N-V2 MiniRouter was delivered with firmware version 2-2.264. We did not change the firmware. WiFi is disabled (via GLI UI) since we use the MiniRouter as Ethernet router only. WAN port is connected to another network (192.168.178.x, uplink) and LAN port (192.168.8.x) is connected to a switch. Several devices in the network are connected to the switch, MiniRouter provides IP addresses via DHCP to these devices (192.168.8.x). This setting works fine for a while.
After ca. three days, MiniRouter stopps working as a router and works as a switch. Thus, all the devices connected via switch to MiniRouter’s LAN (192.168.8.x) port gets IP addresses from the WAN network (192.168.178.x).
In this condition, even a reboot does not recover router functionality of the MiniRouter (works permanently as a switch).
Several resets are needed to get the router into its initial condition working as a router.

We are very thankful for any hint on how to solve this issue and how to use the MiniRouter configured as router (not as switch) permanently.

Best regards,
Birger


#2

can you please check if the LAN and WAN is bridge during boot. This may be a bug in an early version of uboot.

To check this, set up your network, then reboot the mini router.

I assume if the mini router is not rebooted, it should just works fine.


#3

Hi Alzao,

First of all: Thanks for your quick answer. It sounds very plausible, that LAN and WAN is bridged during boot time. This is the case in the default settings of 2-2.264 and 2-2.26.

What do you mean by “set up your network”? We tried to change the functionality of the “switch button” from default to “mode switch”. LAN and WAN is bridged during boot time in both positions of the switch button (left and right), FW 2-2.264.

Is there another option to change the router/bridge functionality during boot time?

Best regards,
Birger


#4

This is a problem in uboot and don’t have anything to do with firmware. Only upgrade uboot can solve this issue.

Do you have usb uart adapter?


#5

Hi,

Sounds plausible, if there is a known issue in the bootloader.

Unfortunately, we/our customer do not have an USB UART adapter. I guess it would be a lot of effort to replace any bootloader manually for each device.

Is there any other way to perform the update of uboot?

Thanks,
Birger


#6

Have a try to enter uboot failsafe, and try using http://192.168.1.1/uboot.html
If this page is valid then you can flash the uboot binary. The source code of uboot is here: https://github.com/gl-inet/uboot-source-for_mtk

Not sure if this is left in MT300N-V2


#7

Hi,

Thanks for the hint, will try that also.

In the meantime, we tried openWRT FW “clean” (2-2.264) provided by GLI which seems to use another boot loader. This one solves the described problem.

BR,
Birger


#8

Hi Alzhao,

FW “clean” solves the problem described above. Router works stable. But issue described on April 12th is still there: Router MT300N-V2 works as switch during boot process (devices on LAN interface get IP addresses from WAN network -> LAN and WAN interface are bridged during boot process).

We have another router GL-MT300A in our lab. This one starts as router only (no switch/bridging during boot time). This is exactly the behavior we expect for MT300N-V2 to use the device in our customer’s environment.

We tried new FW lede-mt300n-v2-2.27.bin (provided last Friday), same behavior. Works stable, but router is switch/bridgingLAN-WAN during boot process.

Concerning to your suggestion, we compiled new bootloader with different settings for the LAN interface (see screenshot below) and transferred it via uboot failsafe to the router. We used last version of code from github.
-> Router is still in switch mode during boot process.

In the meanwhile, we have an usb uart adapter which allows to connect to the router directly. We see the boot process of the bootloader and the FW. And we are able to interrupt boot process to adapt boot loader configuration.

Do you have any additional suggestion? What is the difference between boot loader of MT300A compared to MT300N-V2? Is there any possibility to adapt this configuration to MT300N-V2?

Thanks a lot,
Birger


#9

I think the most updated uboot of MT300N-V2 solves the switch problem already.


#10

Thank you for your answer.

As we already compiled newest version of uboot for MT300N-V2 (https://github.com/gl-inet/uboot-source-for_mtk) and this one didn’t solve the probelm (both ethernet ports are bridged during boot process), probably, we did not use the correct configuration.

Could you please provide a binary of the newest bootloader version via e-mail or in this thread?

Thanks,
Birger


#11

Pls, provide bootloader here in thread, as I this explains some strange effects I had with my MT300N-V2, too. Pls, also provide install procedure, without UART preferred :slight_smile:


#12

Hold on. This seems a problem in firmware. Verifying this problem and will submit the patches.


#13

What ever happened with this issue? Is there a fix for those of us experiencing this problem?


#14

Here is the updated uboot of MT300N-V2.

You can flash using uboot failsafe mode and use 192.168.1.1/uboot.html