New Beryl AX Web Admin/Page Portal keep disconnecting

I am new to this and recently set up a wireguard at home by watching a youtube video.
My Beryl router (Server) is connected to Verizon router at home (Wan to Lan). Then my new Beryl AX router is a client. When I am home, I can easily connect any device to my Beryl AX (client) , whether it’s cell phone or laptop. But when I go outside, to my friend or a coffee shop to test the setup, the Beryl AX admin portal keeps disconnecting. I tried to connect to an admin portal via laptop and cellphone, and it connects for a few seconds and then drops it.
I rebooted, reseted router but nothing works. I would get to my admin page and then a couple seconds later, it disconnects.
I try to work remotely from abroad and wanted to make sure it’s working. Before, my friend helped me with OpenVPN and it worked. I used Express VPN but the speed wasn’t good and I heard that Wireguard was going to be faster. I decided to give a try and set up was pretty straightforward but then this issue came up

Has anyone had the same issue with Beryl AX?


WireGuard is indeed faster but ExpressVPN could be conflicting here. I’d disable it before getting into ‘VPN Cascading’ & just get a straight WG Server/Client link up between your two GL devices.

Here’s a simplified WG Server → Client setup using direct LAN connectivity under the same roof. Change the WG Client’s endpoint IP/address for remote access:

Here’s a Site-to-Site HOW-TO that may be even easier for you.

I now use the latter HOW-TO to manage my GL devices via WG:

1 Like