New router asks for username and password.

I purchased a Brume 2 GL-MT2500A from Amazon which SHOULD be brand new. When I go to 192.168.8.1, I do not get an option to select my language and then set an admin password. I get a dialog box asking for a username and password. Not sure if Amazon sent me a returned product or what. I have tried doing a factory reset. Hold down the reset button, after about 3 seconds it starts blinking at a medium pace and after about 10 seconds it starts blinking rapidly. Release it and it blinks for a bit, then goes out for a bit, then comes back on. But when I go to the admin page after reset (done multiple times,) I get the same dialog asking for username/password. I've tried several options to log in- leaving one or the other blank, admin/admin, root/root, etc. Nothing works.

Another issue is that the WAN port does not connect. I originally connected the WAN to my firewall and the LAN to my switch. LAN came up, WAN did not. As a test, I disconnected the cable from the LAN and plugged it into the WAN port, using the same cable and switchport that worked fine on the LAN port. It does not come up. On the switch, the port shows down/down and 0 bytes of traffic. (The switch has auto MDIX, so that is not the issue.) That may be just an issue with configuration if someone previously had the device and modified the config. But since I can't access the device at all, I can't verify that.

Any advice/suggestions welcome.

I think you are seeing something like this:
IMG_3518

If so refer to this guide

Note: If your browser always redirects to LuCI (http://192.168.8.1/cgi-bin/luci), you can visit: http://192.168.8.1/index instead of http://192.168.8.1.

P.S: If you see LuCi username root password that one that you created

2 Likes