No 2.4ghz wifi. Only 5.8Ghz

Router functioning only with 5.8Ghz both 2.4 and 5.8 is turned on

What is your device model and firmware version?

Slate AX [GL-AXT1800] FW ver 4.2.1

Have you tried to modify the bandwidth and channel parameters of 2.4 GHz Wi-Fi?

Please provide details of your recommendation - examples would be great.

Are the channels 5ghz / 5ghz guest / 2.4chz / 2.4ghz guest all independent and once modified and save it activates onto current setup or DOES IT REQUIRE A REBOOT ??

Please click “Modify” and change “Bandwidth”, “Channel” options in Wireless Page. Then click “Apply”.
It will activate after you click “Apply”. Some settigns of Guest Wi-Fi follow Main Wi-Fi, but 2.4GHz Wi-Fi and 5GHz Wi-Fi are independent of each other.

Do you have any USB devices connected on the router?

USB3.0 device interfere with the 2.4G wifi

YES
My Modem connection is USB-C (from RM520N modem to the SlateAX) “Cellular”

Yes the modem USB3.0 connection caused trouble to 2.4G wifi