No address range available for DHCP request via ZT on devices

Hello everyone!

I have two routers AXT1800 and AR300M16. Zerotier is running on both. Both devices have the following events in the logs like this:

Thu Aug 10 09:35:11 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:15 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:17 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:18 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:22 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:29 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:30 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:31 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:33 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:37 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv
Thu Aug 10 09:35:43 2023 daemon.warn dnsmasq-dhcp[1]: no address range available for DHCP request via zt6ovzd3bv

AXT1800 has firmware version 4.2.3
AR300M16 has firmware version 4.3.6

Please help me how I can fix this issue?

Do you have special configuration?There shouldn’t be information like that.

uci show zerotier
uci show dhcp

Hi lizh,

Thank you for your response.

There’s no special configuration on the routers.

Please see below

AXT1800:

root@router:~# uci show zerotierzerotier.gl=zerotier
zerotier.gl.nat='0'
zerotier.gl.wan_nat='0'
zerotier.gl.secret='XXXXXXXXXXXXXXXXXXXXX'
zerotier.gl.enabled='1'
zerotier.gl.join='XXXXXXXXXXXXXXXXXXXXXXXXX'

root@router:~# uci show dhcp
dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].filterwin2k='0'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].rebind_localhost='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].nonegcache='0'
dhcp.@dnsmasq[0].authoritative='1'
dhcp.@dnsmasq[0].readethers='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].resolvfile='/tmp/resolv.conf.d/resolv.conf.auto'
dhcp.@dnsmasq[0].nonwildcard='1'
dhcp.@dnsmasq[0].localservice='1'
dhcp.@dnsmasq[0].ednspacket_max='1232'
dhcp.@dnsmasq[0].rebind_protection='0'
dhcp.@dnsmasq[0].noresolv='1'
dhcp.@dnsmasq[0].server='127.0.0.1#3053'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.leasetime='12h'
dhcp.lan.dhcpv4='server'
dhcp.lan.ra_slaac='1'
dhcp.lan.force='1'
dhcp.lan.dhcpv6='disabled'
dhcp.lan.ra='disabled'
dhcp.lan.start='2'
dhcp.lan.limit='5'
dhcp.wan=dhcp
dhcp.wan.interface='wan'
dhcp.wan.ignore='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.loglevel='4'
dhcp.@domain[0]=domain
dhcp.@domain[0].name='console.gl-inet.com'
dhcp.@domain[0].ip='192.168.8.1'
dhcp.guest=dhcp
dhcp.guest.interface='guest'
dhcp.guest.leasetime='12h'
dhcp.guest.dhcpv6='disabled'
dhcp.guest.ra='disabled'
dhcp.guest.start='2'
dhcp.guest.limit='5'
dhcp.@host[0]=host
dhcp.@host[0].mac='XX:XX:XX:XX:XX:XX'
dhcp.@host[0].ip='192.168.8.3'
dhcp.@host[0].name='Host1'
dhcp.@host[1]=host
dhcp.@host[1].mac='XX:XX:XX:XX:XX:XX'
dhcp.@host[1].ip='192.168.8.5'
dhcp.@host[1].name='Host2'
dhcp.@host[2]=host
dhcp.@host[2].mac='XX:XX:XX:XX:XX:XX'
dhcp.@host[2].ip='192.168.8.4'
dhcp.@host[2].name='Host3'
dhcp.@host[3]=host
dhcp.@host[3].mac='XX:XX:XX:XX:XX:XX'
dhcp.@host[3].ip='192.168.8.6'
dhcp.@host[3].name='Host4'

AR300M16:

root@router:~# uci show zerotier
zerotier.gl=zerotier
zerotier.gl.nat='0'
zerotier.gl.wan_nat='0'
zerotier.gl.enabled='1'
zerotier.gl.join='XXXXXXXXXXXXXXXXXXXXX'
zerotier.gl.secret='XXXXXXXXXXXXXXXXXXXXX'

root@router:~# uci show dhcp
dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].filterwin2k='0'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].rebind_localhost='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].nonegcache='0'
dhcp.@dnsmasq[0].authoritative='1'
dhcp.@dnsmasq[0].readethers='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].resolvfile='/tmp/resolv.conf.d/resolv.conf.auto'
dhcp.@dnsmasq[0].nonwildcard='1'
dhcp.@dnsmasq[0].localservice='1'
dhcp.@dnsmasq[0].ednspacket_max='1232'
dhcp.@dnsmasq[0].rebind_protection='0'
dhcp.@dnsmasq[0].noresolv='1'
dhcp.@dnsmasq[0].server='127.0.0.1#3053'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.leasetime='12h'
dhcp.lan.dhcpv4='server'
dhcp.lan.ra_slaac='1'
dhcp.lan.force='1'
dhcp.lan.dhcpv6='disabled'
dhcp.lan.ra='disabled'
dhcp.lan.start='2'
dhcp.lan.limit='5'
dhcp.wan=dhcp
dhcp.wan.interface='wan'
dhcp.wan.ignore='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.loglevel='4'
dhcp.@domain[0]=domain
dhcp.@domain[0].name='console.gl-inet.com'
dhcp.@domain[0].ip='192.168.10.1'
dhcp.guest=dhcp
dhcp.guest.interface='guest'
dhcp.guest.leasetime='12h'
dhcp.guest.dhcpv6='disabled'
dhcp.guest.ra='disabled'
dhcp.guest.start='2'
dhcp.guest.limit='5'
dhcp.@host[0]=host
dhcp.@host[0].mac='XX:XX:XX:XX:XX:XX'
dhcp.@host[0].ip='192.168.10.2'
dhcp.@host[0].name='Host1'
dhcp.@host[1]=host
dhcp.@host[1].mac='XX:XX:XX:XX:XX:XX'
dhcp.@host[1].ip='192.168.10.3'
dhcp.@host[1].name='Host2'
dhcp.@host[2]=host
dhcp.@host[2].mac='XX:XX:XX:XX:XX:XX'
dhcp.@host[2].ip='192.168.10.4'
dhcp.@host[2].name='Host3'

Routers are in different networks

@RRoommaann

I have check AXT1800,It have not this issue.Could you give I more information?

@lizh
Sure! What information should be provided?

In theory, ZT should not allocate IP through router’s DHCP.

Could you share the device with gl.inet_support via cloud platform?
I can take a look at the details.

@lizh
Hi lizh,
Yes, I can
is gl.inet_support a user name?

Yes, ‘gl.inet_support’ is cloud platform account.

@lizh Done. Please check availability

@lizh

I figured it out on my own.
One of my devices on the ZT network kept sending DHCP requests to the ZT network. The routers responded with an error because there was no address pool assigned.
This was not a problem with GL-inet routers.
Thanks for the help!