No fping package in 17.x?

I use the fping for finding the best OpenVPN server when I travel. After upgrading my AR300 to latest firmware (which seems to be LEDE 17.x), there is no longer an fping package :-/. Are there any plans, or hope, for getting such a package? It’s an incredibly useful tool. I tried nping and oping, and neither are as useful as fping.


– Leif

Can you try to download from Index of /snapshots/packages/mips_24kc/packages/
and install manually? Not sure if it works because of toolchain change.

The ipk on 17.x is compatible with 18.06. It should works as follow:

root@GL-AR300M:~# wget -O /tmp/fping_4.0-2_mips_24kc.ipk
Downloading ''
Connecting to
Writing to '/tmp/fping_4.0-2_mips_24kc.ipk'
/tmp/fping_4.0-2_mip 100% |*******************************| 15254   0:00:00 ETA
Download completed (15254 bytes)
root@GL-AR300M:~# opkg install /tmp/fping_4.0-2_mips_24kc.ipk 
Installing fping (4.0-2) to root...
Configuring fping.
root@GL-AR300M:~# fping -h
Usage: fping [options] [targets...]

Probing options:
   -4, --ipv4         only ping IPv4 addresses

Yeh, that worked perfectly, thanks!

– Leif