No remote access with Wireguard enabled

I'm using a GL-MT2500 which is working fine as main router(connected straight to the FTTH NTU) Wireguard works fine(I get my static home IP when connected to cellular data on my phone) , but I'm not able to remote access the router when wireguard is enabled. When I disable wireguard the remote access works fine.

Remote access is configured to listen on port 443 and is configured to accept any IP.

Someone can help me out?

You need to access the router via its LAN IP (or the wg one) when connected. Not via the WAN one.

Should work out of the box.

Unfortunately this doesn't work. Either the local IP or WG IP won't work.

Can you try to enable Allow Remote Access LAN in the WG server settings and try again?
See VPN Dashboard - GL.iNet Router Docs 4

That solved the problem, thanks. It's a little bit confusing that this option is not in the WG server settings, but in the general VPN settings

2 Likes