NTFS drive alway mounted as READ ONLY

GL AR 300M, OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.196.56128-9112198)

3.024 version.

NTFS drive always mounted as RO, even though I add options in FSTAB as rw.

Then i tried, adding a string in RC. Local to mount disk as RW, but no luck.

Luci, web says mounted as RW, but when checked from cli (ls -l) or /etc/procr/mounts it shows as monted as Read only.

Always, after a reboot or HDD disconnection, i had to run below command to make it RW.

mount -o remount,rw -a

Any fix for this?

Did you set dmask= and fmask= in fstab?

For ntfs these set permissions for files and folders in fstab.

No, I am not aware of them.

What value to set for them?

Thank you for quick reply…

These values should be handled as the standard linux permissions with the difference that you need to subtract your desired permission from 7. This means if you want to set 0777 you have to use 0000 (which means everybody is allowed to read write and execute).

Set this for testing purpose and if this works start limiting by changing the numbers.

fmask / dmasks though updated in fstab, its not working, those parameters are not showing up /procr/mounts, and no write permissions.

below fixed the issue.

https://openwrt.org/docs/guide-user/storage/writable_ntfs

After few tests / reboots, issue has started again (no permissions) even with about fix with updating rc.local.

Now got new fix, looks like working stable since couple of days.
Deleted mount related config in FSTAB. (btw - fmask / dmask really is not getting applied from fstab only umask parameter seems to be working, but couldnt fix Writer permissions to all with umask)
Deleted additional startup (rc.local) using link in above post.

  1. Enabled anonymous mount from Luci web page for mount points.
  2. Deleted package ‘kmod-fs-ntfs’ based on below post.

Now its working fine. Any new HDDs / thumb drives are showing with full permissions.