Opal/GL-SFT1200 - with WireGuard VPN client, connected devices can't reach internet

I’m trying to set up the WireGuard VPN client on my Opal/GL-SFT1200 (running the latest v4.2.0 firmware). I’m using my own server, and I have tested the configuration to work properly when connecting from my laptop. However, when I upload the configuration file to the router, I am not able to connect to the internet through devices connected to the router. I am able to ping sites, and some network activity seems to work correctly (e.g. using Signal), but I can’t curl an IP or URL:

> curl google.com
curl: (7) Failed to connect to google.com port 80 after 8 ms: Couldn't connect to server

I also can’t SSH into a server by its IP (I get a Connection refused error).

Here’s the WireGuard config I’m using:

Address =
PrivateKey = [redacted]
DNS = 2606:4700:4700::1111

PublicKey = [redacted]
AllowedIPs =
Endpoint = [redacted]:51820

Any idea why this is happening/how to fix it?

I tried the latest snapshot version and everything worked fine.

How did you install v4.2.0 on Opal, latest stable is 3.216 and beta is 4.1.1 beta1 ?

when I try 4.1.1 beta1 (to solve VPN policies issues on 3.216) , wireguard client does not want start, had to roll-back.