Open VPN Connection

I have next to no networking knowledge or experience, so I would appreciate any answers in basic, easily understood terms, without IT jargon.

My aim is to be able to access the files on my Desktop and my two Netgear NAS’s when away from home. I have installed an MT-6000 Router at home and I have a GL-MT300N-V2 to use with my laptop when away from home. I have bumbled my way into configuring the MT-6000 as an Open VPN Server and the GL-MT300N-V2 as an Open VPN Client, (speed is not an issue for me and I already subscribe to NordVPN, hence not using Wireguard). Eash shows a green dot on the Admin panel, which infers they are both connected to OpenVPN?.

However, I am at a complete loss as to how to progress to seeing my Desktop and 2 NAS’s on my Home LAN.

Any help would be greatly appreciated.

Many thanks

Brian

If both client and server show green, the VPN tunnel is ok.
You need to enable “Allow Remote Access LAN” on admin panel VPN Dashboard.

image

1 Like

I have done as you suggest. Both client and server show green so the VPN Tunnel is ok. I also have “Allow Remote Access LAN” on admin panel VPN Dashboard selected, but when I try to connect to my Desktop or NAS’s on my home network, Owlfiles keeps asking for my username and pasword, which are correct because they work outside of the tunnel.

What am I missing?

That could be caused by ACL rule of certain applications.
Please enable the masquerading for LAN firewall zone at the VPN server side, i.e. MT6000.

This way the VPN traffic will be translated as it’s generated from MT6000 local LAN.

Many thanks for your response.

I have enabled masquerading for LAN firewall zone at the VPN server side, i.e. MT6000, but I cannot find my way to the Zones screen in your post.

Can you please point me in the right direction?

Many thanks

Brian

Should be within luci > firewall

1 Like

Hi, does this work? @bde001

Sorry, for the delay but I’m away from home at the moment. It’ll be a couple of weeks before I’m able to give it a try.

1 Like