Openconnect VPN on AR750(Creta)

Hi. I have an AR750 Creta and tried to install Openconnect VPN (Not OpenVPN)
What should I do? Thanks!

Have you tried installing the OpenConnect packages? If so, what are the problems?

1 Like

Yes, I wanted to install an OPEN CONNECT method VPN on my router. The first time I loaded the AR750S file by mistake and bricked it but was able to recover it. I would like to somehow install the OPEN CONNECT method, is there a way to do this? I could not find that file.

Go to the plugin page, update repo and search openconnect.

I am on firmware 4.x so the UI is a different.

1 Like

Thank you. I get this message, how should I handle it? I am just starting to learn this method and don’t understand it. Please help me out.


Failed to send request: Operation not permitted

Collected errors:

  • opkg download: Failed to download 8.10-2 mips_24kc.ipk, wget returned 4.

  • opkg download: Check your network settings and connectivity.
  • opkg install pkg: Failed to download openconnect. Perhaps you need to run

'opkg update"?

  • opkg install cmd: Cannot install package openconnect.

The opkg install command failed with code 255.

can you ssh to the router and use shell commands?

opkg update
opkg install openconnect

I found the video you guys made. I will give it a try!

I tried the Bitvise method from my Windows computer. However, I got a Windows error 10051 and could not connect.

Can you explain? Cannot understand what is it.

I was able to get into ssh with Bitvise using a different device. However, this is the situation all the time.

root@GL-AR750;~# opkg update


Failed to send request: Operation not permitted

** Failed to download the package list from th79/packages/Packages. gz

Ok. I will try out later.

Sorry for your time and effort, I really don’t understand a lot. I sincerely appreciate your help.