OpenVPN: IP is not changing when enabled: GL-AXT1800

I’m using a GL-AXT1800 and have setup VPN on the router. I followed the documentation and used my ExpressVPN to generate OpenVPN credentials, uploaded the config file, and started the VPN. The problem is that when I look up “Whats my IP?” on the web, my location is not that of the ExpressVPN server. For reference, I am living in Mexico, and have selected the NYC ExpressVPN server, but my location still shows as Mexico when the VPN is running. In the VPN dashboard, I do see traffic up and down, and I can browse the web fine… but clearly is seems my connection is not going through a VPN. Please help.

Try different websites that show your IP, some use cached data in the browser.

I tried this but it still does not work. I tried a few different website and also in incognito mode on my browser. I also tried on 2 different laptops.

@SpitzAX3000

Then your OpenVPN configs are not ok; meaning not all lan traffic is being sent through the tunnel; or you have changed the vpn global proxy policy.

OK I think I got it. I clicked on Global Proxy and that seemed to work. Thank you.