Opkg update error

like this, how to deal with it ?

The exit code 8 means server issued an error response. The problem may be with your Internet connection or DNS.
Please see if you can get to any package URL’s using a browser.

this is the page of the url

  1. Change the language of Admin Panel to “简体中文”, then try again.
  2. Or ssh to router, edit /etc/opkg/distfeeds.conf, change fw.gl-inet.com to fw.gl-inet.cn

It does not provide a web page. You will need to enter the full path in the address bar, e.g. https://fw.gl-inet.com/releases/v19.07.8/packages-3.0/ath79/packages/Packages.gz

.cn is ok, .com is failed

I have fixed the .com site issue. Sorry for the inconvenience.

I think it may be the same problem I report in my post when testing 4.2 snapshot firmware in my AR750S. I will try again in a few days
Firmware openwrt-ar750s-4.2.0-1219-1671403982 in a AR750S

I think it’s the same problem.

Testing the 4.3 beta firmware of both Spitz and Mudi, opkg update fails to download:
src/gz glinet_core https://fw.gl-inet.com/releases/v22.03.4/kmod-4.3.2/x750
src/gz glinet_gli_pub https://fw.gl-inet.com/releases/v22.03.4/packages-4.2/ath79/glinet
src/gz glinet_gli_packages https://fw.gl-inet.com/releases/v22.03.4/packages-4.2/ath79/packages

I tried to replace fw.gl-inet.com with fw.gl-inet.cn, same problem: failed!

1 Like

Firmware 4.3 in Mudi

Downloading https://fw.gl-inet.cn/releases/v22.03.4/kmod-4.2.3/e750/Packages.gz
*** Failed to download the package list from https://fw.gl-inet.cn/releases/v22.03.4/kmod-4.2.3/e750/Packages.gz

Downloading https://fw.gl-inet.cn/releases/v22.03.4/packages-4.2/ath79/glinet/Packages.gz
*** Failed to download the package list from https://fw.gl-inet.cn/releases/v22.03.4/packages-4.2/ath79/glinet/Packages.gz

Downloading https://fw.gl-inet.cn/releases/v22.03.4/packages-4.2/ath79/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_gli_packages
Updating database.

Exactly the same error, tried on borh .com & .cn servers.
And because of that, opkg install kmod-fs-ext4, and extroot cannot be installed and activated.
This issue is confirmed on both Mudi and Spitz 4.2/4.3 updates.

The repo is not updated yet.

Any update on this? Im getting the same issue with Mudi under v4.0 beta 10302

root@GL-E750:~# opkg update
Downloading https://fw.gl-inet.com/releases/v22.03.4/kmod-4.2.3/e750/Packages.gz
*** Failed to download the package list from https://fw.gl-inet.com/releases/v22.03.4/kmod-4.2.3/e750/Packages.gz

Downloading https://fw.gl-inet.com/releases/v22.03.4/packages-4.2/ath79/glinet/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_gli_pub
Downloading https://fw.gl-inet.com/releases/v22.03.4/packages-4.2/ath79/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/glinet_gli_packages
Updating database.
Database update completed.
Collected errors:
 * opkg_download: Failed to download https://fw.gl-inet.com/releases/v22.03.4/kmod-4.2.3/e750/Packages.gz, wget returned 8.