Poor WiFi speeds flint 4.4.6

Hi guys

I see this has been mentioned before but not sure if there’s a resolution other than go back to v3.

I’ve got gigabit up and down internet but using the flint I get poor speeds.

ISP router gives me correct speeds.

I’m pretty much running a default set up on the router, auto channel etc and get about 200 down.

How can I sort this?

1 Like

People usually just suggest to change bandwidth and channel but it has mixed effect

I’ve changed bandwidth, channel, power to no avail.

Have you checked the 5g wifi card settings in luci? After I updated it changed my country code configuration which caused issues

Changed it to the correct country code, increased speeds a bit no nowhere nearly expected speeds.

Funnily enough I decided to factory reset and set it back up again from scratch and so far my speeds have returned to what I expected to see now.

Sorry to open this up again but I’m having poor wifi performance again.

Went in to the same room as the router and got the same 300-400Mbps up and down.

Used ethernet cable and was getting almost 1Gbps up and down.

It’s a 2020 MacBook Air so it’s capable of higher speeds.

any advice on how I can improve this?