Question about failover detection mechanism

I’ve reviewed a number of threads on the forum regarding WAN failover. It seems like failover should work by default in the current firmware (3.009 or 3.022), and is configured to prioritize WAN ethernet, then available WiFi APs, then USB modems / tethered devices, and lastly the internal LTE module.

I have an X750 plugged into an upstream network via ethernet cable to its WAN port. The X750 is receiving its IP on this network via DHCP, and uses the upstream router for DNS. When I unplug the ethernet cable from the WAN port, failover to the X750’s internal LTE module works as expected. However, when I leave the ethernet cable plugged in and power down the upstream router, the X750 does not failover to its internal LTE module’s connection.

What is triggering failover from WAN port to other interfaces? Is the physical ethernet cable connection being sensed and, when removed, triggering failover? Or does mwan3 ping a control IP at regular intervals to determine if the current gateway with the highest priority metric is still connected to the internet? How come the X750 does not failover when its upstream DHCP/DNS gateway router connected via WAN ethernet port is powered down?

Thanks for your assistance.

While I don’t have direct answers, I noticed that you mentioned mwan3 and I thought I’d drop in and suggest installing the packages to tweak the mwan3 settings through LuCI.

If you go to MORE SETTINGS and then Advanced, it will take you to the LuCI login page, where you can enter the same password you use to access the GL.iNet interface.

After that, head to System > Software to find available packages.

image

Then click the Update lists button (as long as you’re connected to a WAN connection on the router) to get the latest packages available. In the “Filter” box, type mwan3 and then click Find package. Click the Install button to the right of the packages for mwan3 and then the localized version of the LuCI app you want (for English, choose luci-app-mwan3).

After both of these get installed, reload the page and then click Network > Load Balancing to access these settings and perhaps tweak it to your liking.

image

Hope this helps some or at least gives you a bit of insight.

I’d like to pursue this on a GL-AR300M I have in use with a Verizon device (a Pantech UML290 LTE USB modem). I have it successfully making an LTE connection and then a VPN tunnel back home. This seems to work, but I haven’t done any sort of speed testing.

I’d like to configure it to switch between a couple of ‘known’ WiFi SSIDs and LTE. The setup is on a boat and there are a couple of places where we have access to decent WiFi (marinas, mainly). I’d like the unit to be able to switch to using WiFi for the internet uplink when one of those is available. This would mean stopping/restarting the OpenVPN tunnel after the switch was made from LTE to WiFi.

I don’t need this to be completely transparent most of the time. There are a few situations where failing over to WiFi wouldn’t be ideal, like a crowded anchorage where the WiFi is swamped by too many users. So signal strength alone would not be a totally reliable indicator. But for the most part, I’d want to avoid using LTE when a known SSID is available and to have it failover automagically.

From what I read above I should be able to use the Load Balancing menus via the LuCI interface, right?

Well, when I bring up the Applications->Plug-ins page the luci-app-mwan3 package isn’t listed. Nor is there a Load Balancing item under the Network menu.

I have 3.026 firmware loaded on it, via the LuCi page it says:
OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.196.56128-9112198)

My questions are, can I get the unit configured to do what I want (failover between LTE/WiFi) and where would I find the plug-in to make this configurable?

Nobody? Where do I find the missing luci-app-mwan3 package?