Ralink 5370 USB wireless on Mango V2

I plugged a ralink 5370 usb wireless in a mango v2 and it doesn’t work.

Router doesn’t seem to even power up successfully.


What do I need to do to get it to work?

Router doesn’t power up or the wifi dongle doesn’t power up?

I am not sure if 5370 will work but at least it should not affect the router itself. Can you please check the power adapter?

I tried a couple of different (better, 2Amp) power adapters. I get the same behavior.

The normal behavior is I get a green light and the orange wireless light and the wifi is available.

When I plug in the usb dongle and then power, I only get the green light.

When connecting laptop to lan port, it appears mango is acting as a bridge as I get an IP via dhcp from the upstream ‘wan’ router.

A continuous ping to wan router will work and then fail, work and then fail. I think maybe mango router is repeatedly rebooting.

I remove usb dongle, then power on and mango is back to normal.

I tried two different usb dongles (same brand and model, I just have two).

Any suggestions?

I was wondering if I need to build custom image for this to work?


I see. I checked google and found that 5370 should have been supported. The driver is in the default firmware.

So there are some problems making the router reboot repeatedly. The bridging problem is in the uboot and not related.

I just plugged my own wifi dongle and it cause the router reboot as well. Will debug this problem.