Remote access AR750

Dear all,

after reading tons of threads in the forum, I’m still incapable of remotly accessing the webpage of my AR750 via DDNS function. Any help ?

Currently the AR750 is connected via LAN to a Fritzbox 7590 (which has a public IP address) in which I’ve opened (towards the AR750) ports 80 and 443 (both TCP). Still when performing a DDNS test in the AR750, it says “You’re DDNS is resolved as 81.164…” and “But his router is behind NAT or you do not have a Public IP address”.

Any help ?

hello,

the fritzbox is acting as a router and doing NAT.
you would need to create a firewall rule, on the fritzbox, to forward the ports from the fritzbox to the ar750.
on the fritzbox, it is called port sharing

also, it might be a problem as the fritzbox might be using 443 and 80 for itself.
so better to create port translation rule.
forward port 444 on the fritzbox to port 443 on the ip address of ar750.
then you would access the at750 as https://81.164.xxx.xxx:444

not sure if the fritzbox can do that.
if not, on the ar750, change the port for the webgui to 444, then setup a port sharing rule in the fritzbox
for port 444 to the ar750

for what it worth, not a good idea of expose a router’s web interface to the entire internet.
better to use a vpn or ssh.

Hi @asdffdsa1122,

I’ve indeed found that fritzbox uses port 443 for itself (source), so I followed the instructions (hope well) and changed the webgui of the AR750 to port 444 (image below) and setup a port forwarding in the fritzbox for port 444.
But unfortunately it’s still not working. Any idea why ?
In addition, I might be also trying the way you suggested: via VPN. Any help/guide on how to do so ?
I’d like to access the webgui of the AR750 remotely, so to turn on/off the OpenVPN service in it.

What you are doing is not correct.

You cannot just open port 444 on AR750 as its https is still listening on 443.

What you should do is: set up port forward on your fritzbox, from 444 to 443 on AR750.

You do not need to do anything on AR750 after you enable https

@alzhao I’ve now restored port 443 in the AR750 and setup in the fritzbox (hope correctly) port forward from 444 to 443 on the AR750. Still no access. Something I’m not doing correctly ?

In addition, @asdffdsa1122 was mentioning the possibility to do so via VPN. Any indication where I can find a guide or instructions ?

It must be OK. How about the UI in AR750? How did you enable https?

Send me your IP address using private message and I can check.

Hi @alzhao, please find the setup of the AR750 https below.

image

the external port looks correct.

i think that the internal to port should be 443, not 444

Hi @asdffdsa1122 as the field is grayed out, I cannot modify it. This field is automatically filled in when completing port values in “Port requested externally (IPV4)”.

that is strange, not to allow you to change the dest port.
there should be a easy way to change the web port on the ar750 from 443 to 444.
tho that is not safe to do, to expose a web interface of a router over the interent.
i guess you do not want to use vpn or ssh?

i have setup 100+ routers that sit behind another router, like in your case.
in my case, i need to use a certain router for voip service and double nat creates many problems.

for the front router, in this case, the fritzbox, i dumb it down, disable the firewall, nat, dhcp, etc.
basically turn the router into a modem.

Hi @asdffdsa1122, actually I’d be more than glad to setup a VPN access ot the AR750 as you indicated. Any idea on how I can do so ?

you never setup a vpn before?
perhaps there is some info on the product website

@asdffdsa1122 Not to access the webinterface of the AR750. Is that what you’re referring to ?

you were asking how to setup a vpn.
so i suggested that you go to www.gl-inet.com website and see if there is any info on setting up a vpn.

Hi @asdffdsa1122, as suggested I’ve been visiting the indicated website and here found indication related to the vpn. But as per my understanding these are related to the possibility of using the vpn function of the router, not to create a vpn connection to remotely access the webinterface of the router. Or am I wrong ?

once you setup a vpn server on the ar750, you can access the router gui and if you want, other devices in the lan.

and since you that fritzbox is acting as a router, you would need to forward vpn traffic to the ar750.

create a openvpn server, as it is compatible with almost any device.
https://docs.gl-inet.com/en/3/app/openvpn/

tho i would turn that dumb down that fritzbox like so
https://en.avm.de/service/fritzbox/fritzbox-7590/knowledge-base/publication/show/106_Setting-up-the-FRITZ-Box-for-use-with-another-router/

Hi @asdffdsa1122, I’ve setup a VPN server in the AR750 and opened the related port in the Fritzbox. All worked fine (finally i’d say !!! :slight_smile: ).
But now I’ve discovered that I have another issue: since my goal is to turn on/off the OpenVPN client in the AR750 via remote access, this creates conflicts with whatever VPN protocol is turned on at the moment (either OpenVPN or WireGuard).
Any way I can solve this issue ?

i do not know how to solve that issue of using both vpn client and vpn server on the same router.
there are plenty of experts, hopefull one will stop by soon.

you could enable ssh on the ar750 and access the web gui that way.