Router completely bricked?

trying to access my devices

I have a GL-MT300A and a GL-AR300M and have the same problem on both

the GL-MT300A was working fine until I tried to upgrade with openwrt-ar300m-nand-3.024.tar via the web interface

I power it while pressing the reset button for 10 seconds but it is not working: the wifi network disappears after the reset but after a power off/on it is back to its previous state.

I followed the recover video from https://docs.gl-inet.com/en/3/video/tutor/#how-to-recover-glinet-mini-router-by-u-boot-failsafe

but the router is not assigning any ip I get a self assigned IP 169.254.123.173

that is not normal I should get an ip

so I cannot connect to the router at all

Any idea how I can recover to factory default ?

When running U-Boot recovery, you will need to assign a static IP address to your “desktop”, such as 192.168.1.2/24. There is no DHCP server running under U-Boot.

In U-Boot recovery I did assign the ip 192.168.1.2 but I can’t reach the router. I tried multiple times.

in normal mode I get an ip but can’t reach 192.168.8.1

I tried reseting to factory default with the button in normal mode but no luck either. The default password is not goodlife anymore.

This happened after updating to the latest firmware 3.0.x from the admin interface

Try 192.168.1.1 instead, this is standard in openwrt. 192.168.8.1 is gl-inet, then static of your pc needs to bee 192.168.8.2 or something

Documented here…

https://docs.gl-inet.com/en/3/troubleshooting/debrick/