Router does not connect automatically to Wifi

I was advised on OpenWRT forum to ask my question here.

I have a GL-AR300M-Lite at home, always switched on. My PC is always connected to it. To access the internet from my PC, I’m using my phone as hotspot (wifi): the router is a repeater (or bridge) of the hotspot.

The issue is that when I activate the hotspot on my phone, the router does not connect automatically to it. If I click “join” from the web interface, then it works: the password and SSID have been properly stored in the router.

I am using the latest released firmware.

Because when the router cannot find the ssid it may blacklist it.

Pls try to flash the latest testing firmware which optimized the repeater manager.

Or you can disable repeater manager completely so that the route will always try to connect.

Upgrading the software from v3.019 to the beta v3.022 solved the issue.