RT-AX1800 Flint - issues repeater 5ghz can't find wifi networks

hi All,

as specified in objet i am facing a problem with RT-AX1800 Flint router.
When i try to connect it as a repeater, it can find only 2,4ghz networks around me but not 5 ghz.

I tried to:

  • force 5ghz repeater option;
    -configure 5ghz wifi credential to be connected to
  • downgrade firmware to 4.2.1 to actual 4.5
  • change channel ( many tried from 36 to 161) and/or frequency ( 20-40-80mhz)
  • enter on luci panel option and tried to change country from us to IT ( I am in italy)

it never works
do you have any hint to help me and to make it work?
tks everybody

Do you find them while using luci instead of the GL GUI?

5ghz chip may have active configuration try disable all AP first

reenable after

I can find when I click on “add” on the wlan0 settings. It let me see available 5ghz WiFi around me, yes.

Could you give me any further details on how to do it? Tell me if you need any screenshot to help you to help me tks

I have encountered the same issue on my flint and beryl devices. It doesn’t matter which firmware you’re on as it seems to affect all firmwares on all devices.

Make sure, in the repeater box click the cog and check the both/5g/2.4g option is on both or 5g. If so then:

The problem is the region selection in luci. Leave it on US because it seems to play fairer than other regions.

Once done turn off 5ghz signal in the gui and reboot the router. When rebooted login in and turn ON the 5ghz, select “modify” and check you have access to signals HIGHER than 48. If not then you probably need to reset the router to factory and start over.

Resetting is the short way around as its easier to reset and then program your wifi signals.

before post have the additional steps

Ok I’ll try it.
Just a couple of infos:

  1. the country was originally US and despite that it didn’t work, that’s why I tried to change it ;

  2. when you say to switch off 5ghz WiFi option you mean on luci options or glnet gui interface?
    Tks a lot

In the gui interface. NOT LUCI.

You can try rebooting without changing the region and see what happens and if it doesn’t fix it then try US.

Hi everybody just an update:

I replaced the last firmware 4.5 and reset the router to the default options.
I changed the device which I use to connect to the gui interface. In fact I used my laptop instead of my smartphone (OnePlus 11) and magically the router can now find and give back to me even 5ghz WiFi net around it. So I guess the issue doesn’t depend on the Flint router but it is due to some issue regarding my phone wireless module. Tx everybody for your help

1 Like

Don’t do that if you are not in US. You might run into huge problems because of using an illegal transmitter on unauthorized frequencies.

Hi All, just to give some further infos about the correct resolution I have to specify this:

  1. the issue of lack of WiFi connectivity of the Flint router in repeater mode wasn’t caused bymy smaetphone problems but it depended on my home router.

I’ll explain:

1st Test : tried to connect Flint to my home router (I’ll call it router1). It is router given by Vodafone Italy internet provider. It gone KO (I was using my smartphone to go into the Flint gui but it doesn’t matter, read more below) ;

2nd Test: tried to connect Flint to my parent’s home router (it’s a fritzbox, I’ll call it router2). Flint found 5ghz frtiz WiFi so test gone OK (I was using my laptop to navigate into the Flint gui, but once more it doesn’t matter, see below)

3rd Test : Tried to connect Flint to router1 using laptop : test KO. So nothing changed respect to the 1st test.

I tried to understand differences of behaviour in catching wifi 5ghz by Flint and I understood that it is able to catch only low frequences wifi networks ( channel 36 and/or 40).

So I called my Internet provider to ask them to modify the channel (Vodafone router option are locked on they owner router) and at least Flint has been able to find the 5ghz 1st router too. That’s all. @gl-inet I just ask if they can check and confirm / fix this issue on the new firmware version ready to come.

Hope it can help

This are channels where you don’t need DFS. Maybe this is the problem.

And Flint does not support 160 MHz, just as information.

1 Like