S1300 with mesh B1300 usb tether 3.212

Following upgrade to firmware 3.212 on both devices, and using USB tether Wan, the devices will only mesh if the ethernet Wan port is connected to an active device on the master router. The device doesn’t need to be providing source internet, just connected to it. We are unable to program the master to use the Wan as Lan without losing the mesh.

The S1300 acts as the network DHCP server, to take any load off of our tethered hotspot.

Otherwise, the mesh is the most stable I’ve had since firmware 3.105 and the connection speeds have improved. Another feature which has returned is the ability to use the guest network feature, which has been lost after seeing up the mesh network with 3.105.

What we are experiencing is WIFI devices remain connected to the network, but loose internet regularly. This is so unstable that we had to revert to 3.105. Not sure what is causing this.


If you want to fix a node to act as a master node despite whether wan is connected. Can you following command on the designated master node(only)

sed -i 's/echo "$role"/echo "CAP"/' /etc/hotplug.d/button/30-mesh-button

to revert that change can use command:

cp /rom/etc/hotplug.d/button/30-mesh-button /etc/hotplug.d/button/30-mesh-button

Could you try beta version that fix lbd(the program handle 2G/5G balance) log issue for mesh stability.

Mesh guest wifi is new feature added since 3.212. That may make traffic more complicate, turn it off, to see if internet lost happens. In addition, please try set 2G htmode to HT20 for better connectivity.


Thanks for the followup H!

Have manually updated both the S1300 and B1300 to version 3.215 beta 3. I am not using the Mesh guest wifi as suggested.

Issuing the command “sed -i ‘s/echo “$role”/echo “CAP”/’ /etc/hotplug.d/button/30-mesh-button” had to be done at the master router prior to MESH setup. It should be noted that using router GUI, changing the cable input from “WAN” to “LAN” to use the port as a LAN port has to be done prior to setting up the mesh (doing this after disconnects slave units). Also, the command disabled the normal bridge, which is typically established with changing the cable input, between the user’s WIFI network, “eth1” and "eth0 (the yellow WAN ethernet port.) This also had to be manually setup prior to setting up the mesh network in Luci under Network->Interfaces->LAN->Physical settings. It is as simple as checking a box in the GUI to include “eth0”

Following all of this, going through the procedure to connect the mesh network worked as normal and then allowed the customization of the SSID and encryption for the new Mesh network.

Also to be noted, interestingly, the ability to “sync with time zone” from the main GUI is disabled following issuing the command. Setting of S1300 time and date was acheived via Luci System->System.

Please consider this when pushing future firmware updates or program the back-end to recognize when a USB Wan is connected that it identifies the connected device as a Mesh Master unit, much the same as it already does for a WAN connection.

I also changed the 2G htmode to HT20 in Luci under Network->WIFI->wifi0: Master->operating frequency by changing the width setting from 40 MHZ to 20 MHZ. I understand that this will already be addressed in forthcoming firmware builds.

I will advise as to if this has solved our issues.

The WIFI continues to be unstable with this setup. Ethernet lan connection remains solid, wifi remains solid, but wifi based internet turning on and off at random. WIFI has become useless.

Reverting back to 3.105 until this is resolved.

Thank you very mush for constructive advices.

We’ll do more stress test for debug the mesh wifi internet issue.