Samba auto add share problem

I just got my MT300A router with internal SD card reader.
I have inserted a card and formatet it to ext4. When router boots I see samba auto add the share name “mmcblk0p1”.
I don’t want this name on my card so I have renamed it to “share” and deleted the “mmcblk0p1” share in samba.
Now every time I boot the router the share “mmcblk0p1” is auto added to samba.
How do I delete it so it wont show up after boot?
Is there a boot script that checks for shares/storage devices and auto add this to /etc/conf/samba?

I found out why this share was auto added.
There is a script called /etc/hotplug.d/block/50-samba that will auto add mounted filesystem to samba
When i removed this file then samba auto add will be disabled

So if you connect a USB stick to the router and don’t want it to be auto shared with samba then this is the file to edit/remove.

Perhaps there is a better way to disable this auto share add?

yes. I think this is the way to do it, as there is no such settings in the UI.