Samba greyed out

hello everyone
i finally got around to installing an SD card in the router
i found an issue that after installing both samba and dlna, samba does not see the partition under the sd card but dlna does see it. i thought it might be a sd card issue but why would dlna see it and not samba. can someone point me to a solution? thank you.

running Beryl with firmware 3.211 as an access point.

Should just be a bug.

Can you download beta firmware GL.iNet download center
and try.

If not fixed I will help you manually.

thanks for the reply. i upgraded to beta with no change.

Can you ssh to the router and modify /etc/config/samba directly?

It may be easier to install the luci-app-samba package. This adds LuCI UI → Services → Network Shares to the GUI, where you can just add the SD card in Shared Directories.

I do not work for and I do not have formal association with GL.iNet

i just stumbled onto something weird while trying to set up the sd card.
if i plug in a usb hd/stick, samba recognizes the sd card. if i remove the usb stick, samba does not recognize the sd card anymore. does this mean that one of the modules in not loading correctly or is this a faulty router and i need to exchange it? i’m leaning towards software issues what do you guys think? thanks

PS sd card is the top and the usb stick is 2nd

It is just config messed up when you replug the stick.

I had a similar issue since 3.2.11. Trying installing plug-in Gl-files-brower, it doesn’t install by default for some reason and seems to have a spelling error. Once installed sd cards work without usb stick being plugged in.

The GL.iNet UI only allows 1 Samba share with default name GL-Samba, even when SD card and USB drive are both plugged in, which is why both appears in the drop-down list. The LuCI → Services → Network Shares page referenced in my previous post allows you to set up multiple Samba shares with your own naming,.

You can also view/edit the SD card, USB drive and internal mount points via LuCI → System → Mount Points.

I do not work for and I do not have formal association with GL.iNet

hi wcs2228,
this makes sense via openwrt gui but i have tried using one or the other gui and somehow it messes up the gl gui. it is a very weird issue. can we mark this topic as a bug and closed?

I stick to using only the LuCI UI for Samba and do not use the GL,.iNet GUI because it tends to overwrite LuCi with the GL-Samba share.

You can also install the luci-app-minidlna package that allows you to set up and control multiple DLNA directories.

You can mark this topic closed, GL.iNet may not agree that it is a bug.

I do not work for and I do not have formal association with GL.iNet

i think we should be given the option to run only one firmware not both as this causes config issues which just adds headaches to the setup. these are promising routers but it seems that there are some serious bugs when we want to use features that the routers have.