Samba writing issue?

I’ve tried this on both my MT-300N and the MT-300A with the same result.

I’ve set the USB disk to writeable on the share section of the GLI UI but I cannot write anything to the disk.

Any idea how I can resolve this?

Please add your firmware revision and how the USB device is formatted.

Can you read from the disk?

What is your client OS?

Yes, I’ve got a few GLI devices, tested on MT300n and GL-MT300A on firmware versions 2.19 / 2.20 and 2.24 with same results.

I’ve tested on an android client, Mac OS and Windows.

I can read from the disk but not write. I would reformat the drive but I was keen to have a format which works on Mac (ruling out Ext4 /NFTS for writing).

I read this post on a Raspberry Pi forum which suggested adding umask=0 to /etc/fstab was a fix but on WinSCP when trying to edit fstab it shows ‘No such file or directory’ so perhaps it is not mounted or this fix could be applied elsewhere?

Appreciate the help :slight_smile:

because you are working on shares from the router, not directly write to the usb devices. So there is no need to use MAC format. You have to use a format supported by Linux (which is the system of the router). EXT4 and NTFS is best supported.