Set Up Wifi Bridge with DHCP Lease and separate Wifi Network

Hello,

I am using a GLinet AR750S.
I set up a wifi bridge to access my local network (over WAN port) from my ISP router (Fritzbox) with the main DHCP server. Any client connected to the wifi from my GLinet gets its ip address from my central router / DHCP server.

Now I wanted to create a separate wifi network with a separate SSID. That is connected to a new created interface lanlocal with a static address and dhcp server. This network should also be connected to my home network but keep its subnet. So if WAN is connected to a network with internet access I also want internet access within the subnet. If not, then there is only the local subnet. And here I struggle to get it work.

Here are my setting:

network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd38:fa2a:dcc0::/48'

config interface 'lan'
	option type 'bridge'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR750S-ea4'
	option ipaddr '192.168.8.1'
	option macaddr '94:83:c4:06:2e:a4'
	option ifname 'eth0.2 eth0.1'
	option proto 'dhcp'

config interface 'wan'
	option proto 'dhcp'
	option hostname 'GL-AR750S-ea4'
	option metric '10'
	option ifname 'none'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option disabled '1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

config interface 'guest'
	option ifname 'guest'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'LANLOCAL'
	option proto 'static'
	option type 'bridge'
	list ipaddr '192.168.200.1/24'

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option doth '0'
	option txpower '20'
	option txpower_max '20'
	option band '5G'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option disassoc_low_ack '0'
	option ifname 'wlan0'
	option wds '1'
	option key ''
	option ssid 'oWRT.AR750S.5.0'
	option encryption 'psk-mixed'
	option disabled '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option txpower_max '20'
	option txpower '20'
	option htmode 'HT40'
	option band '2G'
	option channel 'auto'
	option path 'platform/ahb/18100000.wmac'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option wds '1'
	option disassoc_low_ack '0'
	option ifname 'wlan1'
	option key ''
	option ssid 'oWRT.AR750S.2.4'
	option encryption 'psk-mixed'

config wifi-iface 'guest5g'
	option device 'radio0'
	option network 'guest'
	option mode 'ap'
	option wds '1'
	option ifname 'wlan2'
	option guest '1'
	option disassoc_low_ack '0'
	option key ''
	option ssid 'oWRT.AR750S.5.0.WG'
	option encryption 'psk-mixed'
	option flag '1'
	option disabled '1'

config wifi-iface 'guest2g'
	option device 'radio1'
	option network 'guest'
	option mode 'ap'
	option wds '1'
	option ifname 'wlan3'
	option guest '1'
	option disassoc_low_ack '0'
	option disabled '1'
	option key ''
	option ssid 'oWRT.AR750S.2.4.WG'
	option encryption 'psk-mixed'
	option flag '1'

config wifi-iface 'wifinet4'
	option network 'LANLOCAL'
	option encryption 'sae-mixed'
	option device 'radio0'
	option mode 'ap'
	option ieee80211w '1'
	option key ''
	option ssid 'oWrt.AR750S.5.0.Local'

config wifi-iface 'wifinet5'
	option network 'LANLOCAL'
	option ssid 'oWrt.AR750S.2.4.Local'
	option encryption 'sae-mixed'
	option device 'radio1'
	option ieee80211w '1'
	option key ''
	option mode 'ap'

I have a minidlna service running. That shall be accessible from the subnet as well.

Any help highly appreciated.

Regards,

Mario

So you can set the private wifi in bridge mode and set the guest wifi in a private subnet.

Does you configure works for your private wifi already?

You added interface “LANLOCAL”. But I think you can just change the interface guest because there are config already.

You should also change /etc/config/dhcp and enable dnsmasq. Only add guest interface to dhcp