Setting up OpenVPN to Netgear R7000 on MT300N-V2

[[ Response delayed due to forum rules about posting on first day]]

I have two outstanding issues

  1. The Mango does not complete the connection: it is stuck on the connection page with the button saying “abort”. Not connected.

Yet I can surf and access my “local” network devices, ping and tracert….

  1. How do I access the full connection logs on the Mango? I’m just about safe to be let loose with Telnet/Putty

The easiest way would be to run openvpn manually in the terminal and see what you get, but that requires finding the config file. It’s usually stored in /etc/openvpn/. The 4.x firmware creates a random number directory and sticks the profile and auth text file in there. Basically if you find the file and run “openvpn config.file” (with config.file replaced with the actual config file) it will spit everything out to console. Ctrl-C to exit.

  1. Install putty and login at the Mango’s IP address with root/password.
  2. Openvpn logs to the system log, so to read it run logread. There isn’t a separate log file.
  3. You can also run logread -f, which will print messages to the terminal as they are created (ctrl-c to stop). So shrink the putty window bring up the router in a browswer window, start the connection and read the messages in the putty window.

PS: You are on firmware 3.215, yes? Don’t try 3.216.

You should export “For Smart Phone” config and it should just work!

1 Like

Sadly, it does not tonight. Not sure what gone wrong, but I can’t connect now.

i get this response with my config from yesterday


UDP link local: (not bound)

UDP link remote: [AF_INET6]64:ff9b::5609:6a8c:12973

write UDP: Permission denied (code=13)

write UDP: Permission denied (code=13)

write UDP: Permission denied (code=13)


I am - firmware the file I used was openwrt-mt300n-v2-3.215-1013-1665642015.bin

Looks like it’s trying to connect IPv6 - do you have the server set up for that?

No (or not knowingly) and the router is behaving as though DHCP isn’t working (VPN is off!) as i had to manually set the IP address for my laptop to access it

How do i configure DHCP and turn IPV6 off?

Can you share the IPV4, IPV6 info on both the server router and client router?

On the Netgear router IPV6 is disabled.

Maybe check the content of the ovpn and remove ipv6 info if there is?

As i don’t use IPV6 and its off on my netgear router i don’t know how it gets into the ovpn file. It certainly isn’t obvious to my untrained eye. How do I turn it off on the Mango?

Under “More Settings|IPv6” in the webgui.

Thanks. I’ll follow up next week - we’ve got visitors this weekend - and I’m a dead man if seen on the laptop :wink:

OK, I’m back on this. IPV6 is definitely off on the Netgear and Mango router. Things are very unreliable - sometime i can connect to the openvpn server, other times i get similar errors to that above (with IPV6 addresses). I really can’t find any pattern

Thanks. in firmware 3.x ipv6 for vpn is not fully supported. We are addressing this in firmware 4.x

Is it possible that your public ip is ipv6?

Thanks for hanging in there with me Ernest. I doubt it my ISP (Virgin Media in the UK) hasn’t deployed ipv6 at all!

@alzhao as IPV6 is off on both routers and is not deployed by my ISP this isn’t a v6 issue - so what else can i do ?