SF1200 WPA3 not working

I have a SF1200, but activating WPA3 results that a Samsung Galaxy A21s can’t connect anymore to the Wi-Fi (WPA2 works), tested on latest Stable, Beta and Snapshot, other devices like Laptops work, using the A21s on a Flint with WPA3 works. Any Ideas?

Can you let me know, did you change the SF1200’s wifi key?

Have you connected Samsung to SF1200 before. If yes can you choose to forget this network in your Samsung and connect again?

Some devices will not connect to WPA3 wifi when wifi key changed.

No the wifi key was the same, but the samsung reported “wrong wifi key”, the error stays even after reentering the password.
I tried to forget the network, but no success, I tried to change the passwort and ssid of the network, but still same error, changing back to wpa2 and everything works. I also rebooted the router and phone multiple times, I also did a firmware reset of the router.

OK. It does seems a compatibility issue.

WPA3 has compatibility issues with some devices. Not easy to solve.

But the same device has no problems with wpa3 on my flint using snapshot v4.2.0… So I think the problem is on the side of the Sf1200

Yes that is true. WPA3 implementation in different wifi driver is different.