Slate AX disabling 2G wifi when SSD drive is connected

I’m having issues connecting network storage(1TB ssd), I tried different formatting. I’m running Current Firmware Version4.2.3 Firmware Typerelease5. When I format the drive to FAT, FAT32, NTFS or EXT4 and connect it to the usb port on the router, the 2G(wlan1) will disappear and disconnect my devices connected to the 2G part of the network, the 5G will work fine though. If i eject the drive through GUI it won’t start working, i have to physically disconnect the drive for the 2G to start working.

When I format the drive to exFAT it behaves a bit differently. The 2G will continue to work, but I’m having issues with the network storage, in this case I can’t upload files through samba to this drive but i can connect to this drive and view files.

I also tried a newer release of the firmware Version:** 4.4.5. It somehow sorted out the issues but not entirely, when i formatted the drive to ext4, the drive through samba worked correctly, but the 2g wifi network was very unstable for some devices, and to connect my printer I had to check Allow legacy 802.11b rates, which made it very slow.

Anybody have any idea what might be the issue? Thank you.

Thank you, this helped a lot. I sorted it out with replacing the power cable with a very thick shielded one, replacing the included power adapter with an apple 30W charger and a long USB cable that connects to the USB3 drive and also putting the drive further away from the router. Seems to be working without issues so far.

1 Like