Slate AX firmware 4.1.0 release 2 is out

The release note is really LONG…

Download here:


Many thanks indeed for the update. Now I will go ahead and ruin my own impressive record of running firmware 4.1.0 beta3 by upgrading to this latest release. Hope it continues to improve on things.

Here comes the 4.1.0 release 2 …

Download here:


Two problems that I have come across with this version so far:

  1. Packages failed to update.


  1. DDNS not working when VPN client is on even when GL.iNet services are excluded from VPN (and I am not behind a NAT):

How is the fan controlled via CLI in 4.1
I tried running the CLI commands but it didn’t set the fan.

echo 120 > /sys/class/thermal/cooling_device0/cur_state
cat /sys/class/thermal/cooling_device0/cur_state
uci commit glfan
/etc/init.d/gl_fan restart

Edit, this method works:
uci set glfan.@globals[0].temperature=‘30’
uci commit glfan
/etc/init.d/gl_fan restart

How is it that 4.1.0 Beta 5 is now released as a stable version of the firmware with it still being full of bugs?


Pls check

Just update the repo. ARC is working now.

For DDNS, I filed a bug internally. But if you turn on/off the “Service from GL.iNet don’t use VPN” one more times it will fix itself.

Thank you but these are really minor bugs. I was meaning the more significant problems like the frequent dropouts in wireless repeater mode:

This issue is really unbearable and the firmware should definitely be withdrawn from public release as a stable version.

I agree with Almahadeus comment. I am having major issues running AdguardHome with the new release 4.1.0 which has been published. Furthermore, I reverted to version 4.0.3. AdguardHome is running smooth with this release and I am not having any problems with portfowarding for the AdguardHome DNS port from 53 to 3053.
The new firmware 4.1.0 still has some major issues, from my point of view.

1 Like

FYI: The “stable” version for GL-AXT1800 Slate AX is not available as a download anymore, and has been removed. But it still shows up as an upgrade in the GUI.

I had the same problem with repeater especially at boot, but yesterday I re-flashed the latest release and the problem went away for me.
As for Adguard home, I have no problems at all with this release and portforwarding from 53 to 3053, but I have to say that I am running the latest Adguard home release (v0.107.18)

You are right about the repeater problem.

Withdraw the firmware for now.


Thanks @alzhao . Hope you team is able to iron these issues out soon. Please let us know if we can help in anyway with further testing.

The issue is solved. Just need to resend the firmware.

1 Like

Slate ax firmware beta 4.1.0 r6 is out

1 Like

Slate ax firmware beta 4.1.0 r7 is out: GL.iNet download center


Slate ax firmware beta 4.1.0 r7 is now the final version 4.1.0 in the download area. GL.iNet download center

1 Like