Slate AX (GL-AXT1800) - USB/Hard drive issues - not working


I just received my Slate AXT1800 and love it. However, I have an issue when I connect a USB hard drive.

Both of these:

WD My Passport:
Samsung Flash Drive:

My specs:

Mac OS 12.5 (latest)
Router is running latest firmware (beta) - version 4.0.1 release 3

Whenever I connect either of those 2 usb hard drives above (and an older Samsung micro but I don’t have all the specs on that) a few things happen.

While rebroadcasting my wifi wireless (repeater mode I believe it’s called?) via my router I instantly lose 2.4 frequency and only 5g is available.
Under network storage it will see the hard drives, but only say a small amount of room is available (see screen shots). When I enable Samba and then go to select shared folders - nothing is there/cannot be selected (screen shots). I’ve tried enabling WebDAV, and DLNA as well with same outcome.

Thus, I am unable to use this feature and it doesn’t work.

My questions:

What can I do so it properly sees the usb drives and all the available memory it has (there is only a small amount of data so a lot of gigs are free)?

Also, why is only 5g available when I connect a USB drive? As soon as I take them out, both the 2.4 and 5G return.

Any help on this will be greatly appreciated as I need to use this feature.

Screen shots:

It’s looks familiar as this ?

AXT1800 2.4GHZ problems - Beta Testing - GL.iNet (

Hmmm, yes that may be the reason for the 2.4 disappearing. This happens without samba on, but with the hard drive plugged in. I will look into this.

I’m still at a loss as to why it only shows a small portion of my hard drive as free (a few MBs vs a lot of gigs), and no folder sharing options so I cannot use this feature.

Wifi disappeared to me also once. And Yeah, with hard drive instead of usb stick I also had problems without enabling samba. I tried a lot of devices and the behaviour was a little different between them.

yeah, both hard drive and usb stick aren’t working with or without samba. Were you ever able to get it to work?

Actually, yes most of the times they worked. But there were times when was impossibile to get them work. Anything on log when you insert them?

I’m not too sure where I would look to see that info?

If you are on latest firmware just go to applications>log, otherwise go to luci interface>system>system log.

IT shows up under network storage, but says:

191.00 MB free of 29.56 GB

there’s 23GB available and nothing pops up under shared folder settings.

How many partition do you have and what filesystem?

Sorry, I’m not exactly sure what you mean. How can I find this out? It a basic usb stick I’ve used forever on my Mac (the other hard drive I’m trying as well has the same issue and also used on my MAC)

Uh. Sorry I dont use MACs from ages. Most probably you formatted your usb stick on your Mac using APFS file system. Just please try to insert your usb flash drive on your Mac and format it in NTFS or EXFAT file SYSTEM and then try again to insert it in your router.
See this for example:How to format on MAC

1 Like

That worked! I reformatted in EXFAT and the folder I created is now visible in the router admin as well as it now shows the full gigs free.

I haven’t tried pulling files from it yet (i’ll do that tonight)

Thanks so much for your help! :grinning:

PS. Also reformatting made both 2.4g and 5G available for wifi

1 Like