Slate Device with WireGuard Client - Does not reconnect

Hello,

I have the Slate device and the latest “Snaphot” FW and everything works great, but in the latest FW and the FW before, the WireGuard client doesn’t reconnect if the WG connection drops. So I have to login, choose another server or disconnect and connect again.

This outage happens 1x daily - it seems nearly every 24 hours.

But in the stable releases for example my “Mango” it works and the WG connection is allways online.

Where could I take a look to activate auto reconnect?

Thanks

1 Like

I have a similar experience if the internet drops having to manually log into the router to disconnect and reconnect the Wireguard client.

1 Like

Which WireGuard server are you using? If you set up the server by yourself, and it doesn’t have dedicated IP public IP address, it will have such issue.

1 Like

I’m using a dedicated WireGuard server which I set up. It has a dedicated IP address that does not change.

If my GL-MiFi loses internet and reconnects sometimes the WireGuard client does not reconnect automatically. I have to log in manually disconnect the VPN client then re-connect.

This is typically occurring when I am roaming from WiFi to WiFi or from 4G to WiFi.

I’m using AzireVPN and Mulvad.

And this happens with both services (with snapshot fw!) on the Slate.

My Mango with the latest release works like a sharm.

1 Like

i have the same issue as well on the slate daily using wireguard from WireVPN. I was using 3.026 firmware but have decided to revert to 3.025 to see if the issue still occurs.

Rebooting the router does however also fix the issue but it does appear that if WG is active and drops and does not reconnect it blocks internet i guess due to the VPN leak protection.

personally i would like to have an option to disable VPN leak detection if that is the reason that internet is being prevented and just allow it to continue through standard ISP tunneling if the issue can not be resolved.

from what i understand WG uses UDP protocol and should have a permanent connection so unlikely to be server disconnects

Same issue with firmware 3.027 for gl-x750 with Mullvad

If 4G disconnects and reconnects, then I can’t access internet from wireguard.

Same issue with the Slate and 3.025 using my own dedicated Wireguard VPN server with a static IP. Sometimes have to log into the router and manually disconnect/reconnect. Router interface shows an “X” on the VPN icon when it isn’t working. I have shell access on my VPN server and the Slate, happy to do anything to help troubleshoot.

@wellnw Pls check out

Please use ssh to login to the route and use the following command to view when wg cannot reconnect
wg: View the wireguard connection status
route: view the routing list

We are also trying to reproduce the problem.

root@GL-X750:~# wg
Warning: one or more unrecognized netlink attributes
interface: wg0
public key: XXXXXXXXXXXXXXXXXXXXXXXXXX
private key: (hidden)
listening port: 57808

peer: XXXXXXXXXXXXXXXXXXXXXX
endpoint: 185.156.173.26:3005
allowed ips: 0.0.0.0/0
latest handshake: 15 minutes, 24 seconds ago
transfer: 615.73 MiB received, 46.39 MiB sent
persistent keepalive: every 25 seconds
Wireguard can not reconnect. Here your commands

root@GL-X750:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default * 128.0.0.0 U 0 0 0 wg0
default 10.202.209.77 0.0.0.0 UG 40 0 0 wwan0
10.202.209.72 * 255.255.255.248 U 40 0 0 wwan0
128.0.0.0 * 128.0.0.0 U 0 0 0 wg0
192.168.8.0 * 255.255.255.0 U 0 0 0 br-lan