Slate fine for hours, then suddenly unusable

Hi, I’m having a problem with my Slate GL-AR750S. I have firmware version 3.203, but was also experiencing the same issues on 3.201. It’s hard wired by ethernet to my main router, then I have a Wireguard connection in the router. I then connect to the router using Wifi (generally 5ghz).

I’ve noticed that it can work just fine for hours, but then around once or twice a day, it completely locks up. If I try to access any website, it spits out an error that the site can’t be found. I can’t get to the router via its IP address 192.168.8.1 either. I’ve tried waiting but it never comes back up. If I disconnect from the wifi, I can’t reconnect. The only way to regain access is a power cycle. I found this in the logs and think it has something to do with it (it went down at 11:03), but I’m not sure what to try next. Any suggestions would be very much appreciated. Thanks.

Mon Aug 16 11:01:21 2021 daemon.info dnsmasq[9693]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Mon Aug 16 11:01:21 2021 daemon.info dnsmasq-dhcp[9693]: read /etc/ethers - 0 addresses
Mon Aug 16 11:01:21 2021 kern.alert kernel: [ 199.478436] fast-classifier: shutting down
Mon Aug 16 11:03:19 2021 user.info : output={“code”:-3,“cloud_enable”:false,“check_status”:false,“rtty_ssh”:true,“rtty_web”:true,“serverzone”:“”,“serverzones”:[“Europe”,“America”,“Asia Pacific”,“China”],“name”:“xxxxxxx”,“username”:“”,“email”:“”,“bindtime”:“”}
Mon Aug 16 11:13:23 2021 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/dhcp
Mon Aug 16 11:13:23 2021 user.notice ucitrack: Setting up /etc/config/network reload dependency on /etc/config/radvd
Mon Aug 16 11:13:23 2021 user.notice ucitrack: Setting up /etc/config/wireless reload dependency on /etc/config/network

Were the LEDs still on?

Hi, yep, the LED’s all appeared as normal