[solved]Forward webinterface port via SSH command

Hi there,

unfortunately I made a mistake as I am no longer to access the web interface of my GL Inet.
I can log in via ssh, via wireguard connection into but that’s it.
This gl inet is behind another router which and I am wondering that I can’t access even out of the router in front onto the web interface of the GL inet. The device is active but somehow it isn’t working.

Is there any option to set up the forwarding via SSH? This router is at my parents house and they are far away, so no option in the near future to connect via the GL inet’s wifi to get this sorted.

So my setup:

Router A ( → GL Inet ( → wireguard client running on (

connecting via my PC [vpn] ( , fails
also connecting via VPN from router a (, fails

Thank you in advance.

I got it to work. all set - thank you

1 Like

I do not fully understand your setup. The GL.iNet router’s WAN IP is, but what is the GL.iNet router’s LAN IP address? Do you have port forwarding set up to be able to SSH into the router and what IP are you are using with SSH?

I do not work for and I do not have formal association with GL.iNet

Sorry, let me explain more in detail.

The WAN IP of my GLinet is my public address of the WireGuard VPN Server which I have set up. I tried also to stop that service via SSH and rebooted the GL Inet to be not connected via VPN but the result was the same.

The router is reachable via SSH and I can log into but somehow the webinterface isn’t reachable, that’s why I asked if there is any way to open port 80 for the router‘s web interface via SSH.

GL inet is working as an router, therefore the LAN IP is and I assume that I could access the webinterface only when being near to the router to connect via WiFi to.

I am also searching for the config files location like : allow local lan access( VPN menu)
Open ports on router menu( to add port 80, to be able to access web interface from WAN)

It seems strange that you can SSH on TCP Port 22, but cannot http on TCP Port 80

To forward TCP Port 80, you can try adding something like the following to the bottom of /etc/config/firewall and restarting the network or rebooting the router:

config redirect
	option target 'DNAT'
	option name 'WAN to http'
	option src 'wan'
	option dest 'lan'
	option dest_ip ''
	option dest_port '80'
	option gl '1'
	option src_dport '80'
	list proto 'tcp'
	option enabled '1'

I do not work for and I do not have formal association with GL.iNet

You could try using an SSH SOCK5 proxy, this is where you get your SSH client to run a SOCK5 server on a designated port on your PC (localhost). You then tell your browser to use the proxy. I use FoxyProxy on Firefox for this so I can easily turn on or off.

If you set your browser to use the proxy (by whatever means) it tunnels the web traffic through the SSH connection, and you can then break out from the other end of the tunnel. This means you can get your web interface via

This might make it easier to fix the problem if you are more familiar with GL.INET interface and/or LUCI (Advanced interface).

Obviously use htttps if you normally use https!
This is a local connection from the router to itself so “should” bypass wrong forwarding etc. If the web interface is running you can get to it.

connect ssh with the addtional -D option.
ssh -D5100 root@

the above starts the proxy on 5100. These will be local connections so in theory PC firewall will not get invovled.

Either configure your browser to use a SOCK5 proxy (no username or password), or as I said a browser add-in for easy on/off control.

To do this in putty:
Easiest to follow instructions at How To Set up a SOCKS Proxy Using Putty & SSH - Security Musings

Hope this helps