Solved: How to reach max speed on Beryl ax

I connect my samsung fold 4 to beryl ax via usb 3 cable, and i find out the speed difference. my phone connected to mmwave, and speed test on phone showed speed about 1Gbps, but did speed test connected to beryl ax, always couldn't pass 320mbps, either through beryl wifi or lan to my fold 4. If i directly connect to z fold 4 wifi hotspot, i can get about 500 or more Mbps speed while phone itself speed test over 1Gbps. How could i improve the beryl ax speed?
TLDR: Device A connect via Beryl Ax and USB 3 cable to Z Fold 4, speed max at 300Mbps
Device A connect to Z Fold 4 wifi hotspot can reach 500 Mbps.

The speeds seems normal via USB tethering.

Maybe you can test wifi repeater to lan.

Tested in repeater mode, however, my firewall ttl to 65 no longer work. Any idea what commands i should try to make ttl=65 work again?

What is your firmware version?

4.6.2
Bythe way. On this firmware, I can see option for enter ttl while connect to tethering. But i dont see this ttl option under repeater mode
Once i switched back to tethering mode, my firewall commands worked again for ttl=65
Seems like the firewall commands doesn't work under repeater mode?

In repeater the TTL is here

Really appreciated. The repeater mode finally worked, followed your screenshot and i no longer need firewall commands to bypass ttl, finally reach to around 500Mbps expected.
Just curious, Is the USB0 tethering maxed out around 300Mbps even i used USB3 cable, and fold 4's usb is usb3 standard? I also tried USB to Ethernet connector to my phone and Beryl AX WAN, speed is around 200 Mbps, seems like there is capacity limited through USB method?
Looking forward a MMwave version Spitz AX X3000, i would definitely get it to enjoy Gbps high speed Internet :smile::smile:

Currently I don't know if it is hardware limitation or software problems.

Anyway you cannot expect real USB3.0 speed for these embedded devices.