Spitz GL-X3000 Repeater WiFi no longer connects or finds Networks

Last night I was using the campsite wifi using repeater mode on the router, which worked fine for a while. This morning I tried to change to a different wifi and it no longer connects or finds any networks. Tried manually connecting, deleting the SSID and reconnecting, rebooting the router, nothing, same thing, not even finding the networks, just says Operation Timed Out, try rebooting or something.

Current Firmware Version
4.0
Firmware Type
0408release4
Compile Time
2024-04-19 16:03:01(UTC+08:00)

Found these errors in the logs, happy to send the full log across:
...
Thu Jun 6 10:16:25 2024 daemon.err repeater: (/usr/sbin/repeater:1661) /usr/lib/lua/gl/wifi.lua:123: bad argument #1 to 'sub' (integer expected, got nil)
....
Thu Jun 6 10:16:17 2024 kern.err kernel: [ 2210.971103] 7981@C03L1,ExtEventBeaconLostHandler() 176: AP Beacon OFF!!!
...
Thu Jun 6 10:16:18 2024 kern.err kernel: [ 2212.169917] 7981@C12L1,EDCCAInit() 21006: EDCCA compensation: uni_compensation=0, bw_compensation=0, final compensation=0
...
Thu Jun 6 10:16:19 2024 kern.err kernel: [ 2213.732226] 7981@C14L1,ba_resrc_rec_add() 1395: ba_resrc_rec_add Freeing previous Debug BA Rec 000000000f4c3678

I've had that but it was kicking me out of the router admin by dropping the WiFi network and the timed out error appeared. Try to connect on the different ssid's you have or ethernet directly to it. If it's not a bad signal then reset the router to factory. I think I had to connect to mine via ethernet to sort it out.

Issue it is not showing any SSIDs anymore, and there are about 5 I can see in my phone. It worked fine for a day or so, seems something got corrupted in the router config... Having many issues with this routers WiFi...

OK you know better. Maybe you should open your own forum. I don't see the point of asking for advice if you're going to assume you know better.

Good luck.

Eh? I didnt assume anything. My issue seems different to yours, I don't get kicked out from router admin, my connection to the laptop stays fine, its the repeater that cant connect/see any SSIDs. Thanks for suggesting to reset the router, i will try that later

Mine was doing the same as yours, couldn't see any networks to repeat, but when connecting to its Ssid it would boot me out and off the entire network. It was your situation but worse. Resetting to factory seemed to have fixed it. No clue why it did it. Never found out. Probably through messing with regions in luci.

1 Like

Hi,

Though the syslog, cannot learn about why repeater does not scan, but know the Wi-Fi configuration probably have some issue from 'bad argument' .

  1. Try restoring the X3000, and see if it can scan the SSID as repeater mode.

  2. Try scan the SSID in command line of X3000, to see if it can print the SSID list:

    iwinfo wlan1 scan

Can you see X3000 wifi on your phone?

Yes, the user can connect to the router fine. The problem is that it doesn't see any WiFi signals to connect to as a WiFi repeater. Presumably for fail over..

I suggested a factory reset after myself encountering a very similar and more destructive version of this fault. The reset seemed to have fixed it so far.. User is yet to reset and post back.

yes I can connect to x3000 over 5g or 2.4g, via phone or laptop, i access admin portal

Resetting firmware did not help. Still was not able to see any SSIDs. What worked is changing "Band Selection" in Repeater Options from "Auto" to "2.4Ghz". When I did that I can then see networks and connect to them. There seems to be a bug with "Auto" setting. Please investigate.

1 Like

This is what I do since the beginning with my GL A1300 - I fix it to 2.4GHz to connect to the hotel-WLAN and use non-DFS channels on 5GHz for my internal network.
It works without any problems in many hotels until now.

1 Like