Tethering not working on AR300M with Galaxy S10

Hello, I’ve been using an AR300M for maybe six months now and it’s been working great. Recently I upgraded from the Galaxy S8 plus to the Galaxy S10 plus and I’m no longer able to get tethering to work. I can plug in the phone via USB C and enable tethering on the phone, but when I press Connect on the router page it spins for a bit and then gives the error “Error connection failed! Please check if hotspot is enabled on your phone or modem”.

I can connect using the tethering option when connecting an iPhone and with a USB hotspot, but the Samsung Galaxy S10 won’t connect. I’ve tried three different good quality USB C cables (two Samsung cables and one Anker cable) to no avail.

I can use my phone tethering to my computer just fine (using the connection to type this now). So the problem appears to be a compatibility issue between my phone and the AR300M.

Router is currently on the stable firmware (3.19 I believe). I tried uploading the test firmware .tar file from https://dl.gl-inet.com/firmware/ar300m/nand/testing/ but it gives an error.

Can anyone confirm if they can tether using these two devices?

This issue has been fixed in the latest test firmware, you can upgrade to the latest firmware and try it out again, https://dl.gl-inet.com/firmware/ar300m/testing/