Tethering prioritized over ethernet

GL-MT2500 Brume 2
Firmware release 8 version 4.5.0

Primary modem connected via ethernet (~150mbps)
Backup 4G modem connected to USB “tethering” (~50mbps)
Intended to switch over for fallback only

Multi-WAN
mode- fallover

Interface priority

  1. ethernet
  2. Tethering

When tethering is enabled, internet is routed over the USB/tether, instead of ethernet as expected.

Have tried adjusting “metric” in /etc/config/network which does not solve.

config interface 'wan'                    
        option device 'eth0'              
        option proto 'dhcp'               
        option force_link '0'             
        option ipv6 '0'                   
        option metric '10'    

config interface 'tethering'              
        option proto 'dhcp'               
        option ifname 'eth2'              
        option metric '30'                 

solved

  • both tehered modem and primary ethernet router had gateways 192.168.0.1 which was confusing things.

  • Changed one to start at 192.168.1.1 and now all good.