Tor connectivity working but notanymore

I have a GL-MT1300 working in router mode.
When I bought it, few months ago, I only activated Tor with country Greece and since then it was working.
Only yesterday I understood that with Tor enabled I have not Internet. When Tor is disabled I have internet.
What is the problem and I have no connectivity with Tor enabled?
Firmware is 3.200
The router is connected to the operator router via WiFi.
TV is the only device connected to the router with cable. I did not change anything in my home network configuration.
When Tor is enabled I get a popup saying ‘success’ but at the bottom of the screen it gives a message in red “in itializing”.

Thanks for the help
Spiros

Can you upgrade to firmware 3.201?

It should be a bug in old firmware.

I did the upgrade to 3.201 and still the problem is not fixed. It says “Initialisation for configuration” and remains there. Previously it was giving more indications for success connectivity.

Can you check /etc/tor/torrc and /etc/init.d/tor and send me the content? This should definately fixed

I need to have the root password. Can you supply me with it?

It should be the same as your login password.

/etc/tor/torrc:

Capture_1st_dir

/etc/init.d/tor:

Checking your content, the settings are wrong. This was fixed in 3.201 (release version) for sure.

As you said you upgraded, can you let me know what is the exact version you upgrade? You can give a screenshot of the firmware upgrade page.

Yes, of course, here it is

I don’t know why. Maybe the settings was reserved from old firmware.
you can just reset the router and start over?

This has been done several times with no effect.
Can you give me the files containing the correct contents ?

You can modify this file

image

I made the change in the file and now Tor seems to have started but not entirely (pls see in below screenshot). Still no internet with Tor activated.

Better not select any country. Just use random.

I’ve tried with “Random” and worked but only once.
When I tried again with “Greece” it failed (stuck at 50%) and when I set it up back at “Random” did not manage to complete Tor network setup ever since.
It is quite unstable and was not working like that before. I was using it with “Greece” setup for months.

Now it is working good with Greece too.
It must have been an issue with the Tor servers, not the device. Thanks for the support

1 Like