Tor on mt300n with 1.4

With a reset router “openwrt-mt300n-tor-1.4.bin” does not provide a working connection with default settings.

I later tried the older firmware “openwrt-gl-mt300n-tor-luci-1.0.bin” and the connection works perfectly, no tweaks.


Both of these firmwares (found here: GL.iNet download center) are still very old. Will a new working firmware ever be released? How can I build my own?



the 1.4 version should work without problem. Be sure to check the docs Overview - GL.iNet Docs

You need to use the switch to control if you want Tor network in 1.4

Yes I tried that a few times. Also reinstalled/reformatted/reset. I spent awhile reading the docs and forums before posting.


I can log into the front-end when tor is off and it says tor is running. When I flip the switch my client is able to obtain an IP from the router but nothing loads, I only get timeout errors. Cannot reach the internet.


Is there an update planned?


Thank you for all of your work. I love the gli project.

When the switch is in the right, you have normal Internet, but in the UI it says that Tor is running is normal. Tor process is always running so that when you switch the button, it doesn’t turn on/off. Tor needs long time to start so we don’t turn it off. The switch only redirect your traffic to Tor.

I think your problem is caused by something I don’t know. But I will check the Tor firmware more carefully once again and maybe update to v1.5.