Total newb who thought this would be easy

I have a GL-MT300N (not V2) and I’ve updated the firmware to 2.265.

This is what I want to do: I want to livestream from my laptop to Facebook and a camera using a school’s guest WIFI. I can do this using my home router easily, but as soon as I use a public WIFI setup, my ATEM switcher and smart controller are no longer able to find my laptop and communicate with each other, so I think their system is blocking computer to computer networking. So, I have a 5 port switch and this GL-MT300N, so I created a new connection, REPEATER in WISP mode, and get the GL-MT300N to connect to my home WIFI network to simulate what it would be like to connect to the school WIFI. I’m able to get the internet through this new WIFI connection, but I disable the WIFI on my MAC, and then run a cable out of the LAN port of the GL-MT300N to the network switch, and then everything connects to that switch (nothing is using WIFI, all LAN). I’m writing this query on my MAC, it’s connected by cable to the switch, to the GL-MT300N, and back and forth to the home router using the GL-MT300N’s WIFI. I can connect to Facebook and I should be able to livestream from my own mini-network right? But when I look at the attached devices, it sees my MAC, but it doesn’t see my ATEM mini switcher and can’t find it. What am I doing wrong? Is it something I’m doing wrong, or is this device unable to do what I want to do?

No VPN or other complications, the GL-MT300N, as a DHCP server, should be giving the ATEM mini device a unique network address if it’s connected to the switch, right?


Feel weird replying to myself, but I thought I should mention that when I had the option of choosing WISP or WDS, I chose WISP because every time I used WDS, my little router just stopped working. It didn’t connect to anything and was unresponsive. However, in the advanced controls, I see that despite choosing WISP, I am actually connected as Access Point (WDS), so the WDS option in the menu must by a client WDS and the IP address isn’t a new LAN address for the network as I thought, it’s asking for the server LAN that feeds the new WDS. My bad, but maybe this helps someone out.

Also, I have solved my problem, my computer is recognising my ATEM switcher now, it has been assigned its own IP, but that’s why I find myself in the Advanced settings, I’m still trying to find this device in the list of devices as it appears not to be connected.

So just for me to understand this as an idiot… you have the computer connected to the ATEM via USB? and the ATEM goes to the gli via ethernet cable?

Thats how it should go as far as I get from the website… The ATEM should be doing all the dirty work of the livestream processing…

You have that exactly right. I didn’t include that in my description because I’ve never used the network features of the Atem before and I didn’t plug it in. I was under the mistaken belief that if it was networked, it could be operated remotely and thus, didn’t require the USB be plugged in. But after failure after failure, I plugged it in and it was found right away and assigned an IP under my new IP naming scheme. But, I still can’t find it as an attached device, Incan only see the attached devices on the home network, and my Mac. But so far, I’ll be able to do what I was hoping to do. But I welcome any advice anyone has on making this work better. I guess network control requires at least on computer is connected via USB-C to the Atem, and that in a sense, the commands are being sent to the Atem by that computer by proxy.

I think that might be the only way to go. Remote to the controlling computer and use that computer via the software and remote connection to control the ATEM… If that makes any sense.

I think it would be wise to find out exactly what the ATEM is capable of and proceed from there. It could be possible to remote access it directly and be a case of port forwarding, static IP or getting it an outside connection somehow… Does the ATEM software allow network addresses?

Yes, I believe that you can assign ATEM hardware addresses as big production companies may have a stack of switchers and can’t risk DHCP an address conflict.

I think I misunderstood how the ATEM was connected because I know ATEM switchers can be operated remotelyby someone connected in a control room who is only connected only by WIFI or by CAT6 cable, and switching the cameras in a room somewhere. It lead me to believe that the ATEM could be connected to the network alone, but it’s probably not the case, wherever the physical ATEM switcher is, it needs to be connected to a computer somewhere. But the software needed to visualize the actions of the switcher can be a tablet, laptop, etc… and doesn’t need to be the computer that is connected to the ATEM (if that makes any sense).

Thanks for helping out!

That makes perfect sense. You’re welcome for the help.