Turned My GL i Brume into a Handshake Node

Handshake is now acting as my DNS and resolving handshake TLDs for the pad, good Times indeed

1 Like

Do you mean https://handshake.org/

Can you share your settings so that others may find it helpful.

1 Like

yes, sure
I wanted to run the node so I needed a higher version of nodeJS that is currently on the
device (ver 8), the node calls for ver 10 or greater, so after giving up on the updating route I
try ubuntu , but I did not like it, with a similar idea I install ArchLinux using a usb (https://archlinuxarm.org/platforms/armv8/marvell/espressobin)following step by step instructions and getting access to the serial connection( yes I had to open the little guy) connected my cables and interrupting the booting process type the common commands in the instructions and finish booting from the usb. ufff tire of typing get back with how I install the HSD node, if you can make it this far the rest is interesting

1 Like

ok the second phase, once I new everything was running correctly like it should , with no intervention, the default settings got me cover, very nice. I started with setting the time

timedatectl

pacman -Syu update

pacman -Syu nodejs npm

pacman -Syu unbound

pacman -Syu git

pacman -Syu make

pacman -Syu gcc

npm install loady

git clone git://github.com/handshake-org/hsd.git

cd hsd (change directory to hsd)

npm install --production

once you are done with all this the you are done , you can test it for now by

./bin/hsd

ok too much typing , the last phase will let me run the node automatic so it just runs , if is not running I will not get my DNS , break

oh I forgot the link that I used (http://wiki.espressobin.net/tiki-index.php?page=Boot+from+removable+storage+-+ArchLinux) was the one I used , I had no
success with that storage , so I used a usb and this link was useful

the final phase, I noticed that dnsmasq and system resolve was listening to ports I needed to
use

netstat -tulpn

so before I nix both of this services I install a basic dhcp server

pacman -Syu dhcpd

pacman -Syu cronie ( more on this later…reference https://wiki.archlinux.org/index.php/Cron)

and disable both services by

systemctl disable systemd-resolved

systemctl disable dnsmasq

systemctl mask systemd-resolved (not let it start at boot)

systemctl mask dnsmasq

by doing this the internal resolver gets ax and the dhcp,dns, provided by dnsmasq gets ax
now my dhcp server becomes dhcpd after locating and editing the file

nano /etc/dhcpd.conf with

option domain-name-servers 10.0.0.1;
option subnet-mask 255.255.255.0;
option routers 10.0.0.1;
subnet 10.0.0.0 netmask 255.255.255.0 {
range 10.0.0.150 10.0.0.250;
}
(yea the whole content of the file gets erase with just whats above )

in order to start this service at boot

cp /usr/lib/systemd/system/dhcpd4.service /etc/systemd/system/dhcpd4@br0.service

Then edit the ExecStart line to include the interface:

#nano /etc/systemd/system/dhcpd4@br0.service

… [Service] … ExecStart=/usr/bin/dhcpd -4 -q -cf /etc/dhcpd.conf -pf /run/dhcpd4/dhcpd.pid %I

(https://wiki.archlinux.org/index.php/Dhcpd) reference at the bottom of the page

now I had dhcp running again , next was having my node start at boot , I did this by running cron

EDITOR=nano crontab -e

@reboot $HOME/hsd/bin/hsd --ns-port 5300 --rs-host 0.0.0.0 --rs-port 53

enter then exit

systemctl enable cronie.service

check your hard work by

netstat -tulpn

dig @127.0.0.1 www.ietf.org +dnssec

dig @127.0.0.1 -p 5300 org +dnssec

1 Like