Turning RTL-SDR to rtl-tcp sdr touch won't connect

Using gl. Inet ar300m, installed RTL-SDR packages and rebooted. Went to the sdr touch and connected to network rtl-tcp and entered ip address port 1234. Says fails to connect. Anyone know if I am missing any additional software or am I entering the address and port correctly?

I feel like I am missing one silly little thing and then I am finally up and running.

1 Like

Maybe you have to configure rtl-tcp’s configuration file /etc/config/rtl_tcp. And restart it via /etc/init.d/rtl_tcp restart.

Solved it, ran putty for type root, enter password, added code tl_tcp -a -n 128 -b 16

Works fantastic! wireless all the way. But need this to be apart of the configuration so i don’t have to do this every time i run it.

Any ideas?

You should configure the uci file.

uci set rtl_tcp.main.disabled='0'
uci set rtl_tcp.main.buffers='8'
uci set rtl_tcp.main.num_linked_lists='128'
uci commit rtl_tcp
/etc/init.d/rtl_tcp restart

Please confirm that it ran.

Thanks I will give it a try. Also I am trying to go simple low budget antenna to listen to radio in the 900 mhz, does anyone have any suggestions? I am wondering if I could get away with using my HDTV antenna with Lna’s and a SAWbird. Goal is to eventually connect to Goes-r and see some pretty great feeds. But I like to be able to see what else I can listen to as well with it.