Unable to load website to set up travel router for boosting campsite wifi signal

Hello there! Our new GL mudi works for boosting our SIM signnal, but the website does not load to set it up without SIM to boost a signal.
Not being savvy with tech stuff, I am not sure what to do next.
Thank you!

Have you tried turning it off then on again? Not trying to be funny this can usually fix 90% issues. Mudi is hold down power button for at least 5 seconds and display will say powering off. You can try in a private browsing window. Are you connected to the Mudi Guest wifi Network and not the main wifi network?

You should use http instead of https.
What does your browser show when you visit

Hello, it shows: took too long to respond. Using Samsung or Huawei android phones or laptop on wifi or mobile data.
I did download the app and somehow maneouvered myself to use without cloud and have enabled the repeater. So problem solved. Phew! Thank you for trying to help!

Hiya, thank you, it shows the same, but I solved it with the app.